Skip to main content
Microsoft Dynamics NAV forum
Suggested answer

XmlPort error " You must specify table data source

editSubscribe (0) ShareShare
ReportReport
Posted on by 467

im creating Xmlport to get output of the sales header table and sales line table in TXT file 

all the sales header table is ok , but when i added the sales line table i got the below error 

0624.xmlport.jpg

  • Samer Baskhayroun Profile Picture
    Samer Baskhayroun 467 on at
    RE: XmlPort error " You must specify table data source

    1-i need to filter from the Location in the line not in the header

    2-i need to remove the double Quotations from one filed only not from all of them  

  • Suggested answer
    Community Member Profile Picture
    Community Member UG Leader on at
    RE: XmlPort error " You must specify table data source

    I'm not sure I understand No 1. If you only need to filter with location and you don't need any line information, there is a location code on the header as well (field no 28) that you can filter with.

    Add the location code to filters:

    pastedimage1568787255779v1.png

    2 Remove the field delimiter from the xmlport properties.

    pastedimage1568787001666v1.png

  • Samer Baskhayroun Profile Picture
    Samer Baskhayroun 467 on at
    RE: XmlPort error " You must specify table data source

    Thanks a a lot , that solve the issue

    i have 2 questions

    1- in the below screen shots the i added location from the sales line , and i don't want to have the location in the output , i only use it to filter the data , how can i do that ?

    3817.filter.jpg

    2- the out put will be like below

    SO000012","09/17/19","01613","English Guernsey Cattle Societ","Scotsbridge House, Scots Hill","Rickmansworth","","GBR"

    every thing is OK but i need to have the date ( 09/17/19) with out the double quotation to be like that :

     09/17/19

  • Suggested answer
    Suresh Kulla Profile Picture
    Suresh Kulla 43,636 on at
    RE: XmlPort error " You must specify table data source

    You need to indent the fields under the SalesLine, just like you did for the Sales header fields. The Test field is set to use the Sales Line:: Description but it is not intended under it.  Indent that field and any other fields you add for the sales line.

  • Suggested answer
    Community Member Profile Picture
    Community Member UG Leader on at
    RE: XmlPort error " You must specify table data source

    Hi,

    You need to indent the line under Sales Line and it will compile.

    Tero

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,045 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,570 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans