web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Service | Customer Service, Contact Center, Fie...
Suggested Answer

D365 Online Plugin failures - No sandbox hosts currently available

(0) ShareShare
ReportReport
Posted on by 21
 
Hi guys.
 
We are experiencing a very frustrating issue for the past 6 weeks or so (it started happening just before Christmas).
We have a D365 online instance.
We are getting regular reports of users getting the message /The plug-in execution failed because no Sandbox Hosts are currently available/ when they attempt to save in CRM.
The reports we're getting are mainly on saving contacts and opportunities but it seems that it's happening all over the place (users report it on these 2 entities because they are the main entities that they work on).
 
Logged a ticket with Microsoft but not getting anywhere fast with it.
They have been running some traces and sent a breakdown of plugins where the issue has been reported and it is happening on loads of them now.
They have told me to review the logic of our plugins but to me that's crazy as this has only just started happening in the past 6 weeks.
Many of these plugins are the same today as they were when the cloud system went live 5 years ago - nothing has changed in most of them (some have changed a small bit but all were working fine until just before Xmas).
So it makes no sense to me that there is now suddenly problems with these plugins that all worked fine 2 months ago. There has to be something fundamentally wrong in the background platform somewhere.
 
Has anyone had this issue before and if so what was the resolution?
Dealing with Microsoft support is a very frustrating experience.
 
Many thanks in advance for any guidance.
  • Suggested answer
    Adrian Begovich Profile Picture
    1,032 Moderator on at
    Hi bcbc,
     
    The “The plug-in execution failed because no Sandbox Hosts are currently available." error can occur when the background Sandbox Processing Service stops running properly. The Sandbox Processing Service enables an isolated environment to allow for the execution of custom code, such as plug-ins. This isolated environment reduces the possibility of custom code affecting the operation of your organisation. On the on-premises version of Dynamics CRM this issue could be resolved by ensuring that the Microsoft Dynamics CRM Sandbox Processing Service is running. However, since you are using Dynamics 365 online, you will need to raise a support ticket with Microsoft to get them to check that the background processing services are running correctly.

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the July Top 10 Community Leaders

These are the community rock stars!

Leaderboard > Service | Customer Service, Contact Center, Field Service, Guides

#1
Syed Aqib Raza Profile Picture

Syed Aqib Raza 42

#2
11manish Profile Picture

11manish 21 Super User 2026 Season 2

#3
Travis South Profile Picture

Travis South 19

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans