Skip to main content
Suggested answer

PSTL error : Illegal address for field 'syShortcutMstr' in script 'GPSTK_RecreateTable'. Script terminated.

editSubscribe (0) ShareShare
ReportReport
Posted on by 28,002 Super User

Today I was trying to rebuild all the DYNAMICS system tables from a customer's environment, as we had made some changes to the account framework, and needed all the Financials tables recreated as well to adjust for proper new length.

Using the PSTL > Toolkit > Recreate SQL Objects > Recreate Tables for Selected Series, I was able to redo all the data GL related tables in all companies without getting a single error and losing a single data.

At the end I wanted to redo also the DYNAMICS system tables, just in case some of them would have any relation, and also to see how many tables would be recreated.

At 29% into the process the PSTL threw up an error with the message "Unhandled script exception: Illegal address for field 'syShortcutMstr' in script 'GPSTK_RecreateTable'. Script terminated" on the table SY01990. 

After checking its content, I noticed that this table contents all the user's navigation shortcuts from their home page (the one on the left side). I tried several tricks, like dropping the table manually in the system after saving the data, and having the PSTL re-create it, but no luck, whatever and however I tried, it would end up with the same error.

I took to my brand new GP 18.2 demo (Fabrikam) setup and ran the exact same process, but this time just on the single table SY01990 that was already identified as the source problem.

pastedimage1583882091927v1.png

And I was able to reproduce the exact same error. 

I scoured the net and couldn't find a single report for the exact same issue.. of course the error message is pretty generic if your remove the table name 'syShortcutMstr' (which is SY01990). Maybe Microsoft could chime in and confirm that this is indeed a bug ? 

Thanks in advance for any reply.