Issue:
Missing “prvReadAsyncOperation” privileges when trying to sync the data between BC and CRM.
error "Principal user (Id=xxxxxxxxxxxxx, type=8, roleCount=3, privilegeCount=136, accessMode=4), is missing prvReadAsyncOperation privilege (Id=e8" when creating a customer card in URL
"businesscentral.dynamics.com/Tenantid " enviroment. The user with above-mentioned ID does not exist in the tenant
Cause:
This is the read privilege for the "System Job" entity. Sometimes it is required, depending on which plug-ins and solutions you have installed on the CDS environment.
On a bare CDS environment with no solutions and plug-ins it is not required, but on some - it is.?
Solution:
The fix to stop seeing these errors will be available in 16.5 (prvReadAsyncOperation is included in the integration solution). For this case we will need to add the privileges manually by following the guide below:
1.Sign in to "">XXXXXX.crm4.dynamics.com" with an admin user
2. Choose the settings wheel in the top right corner, then advanced settings
3. Under Settings, choose Security, then choose "Security Roles"
4. Choose the security role "Business Central CDS Integration" to open its card.
5. In the "Security Role: Business Central CDS Integration" card, choose the "Customization" tab
6. Scroll down to find the "System Job" entity and add Read privileges for it (the second circle from the left should become entirely green). See the pasted image below.
7. Choose "Save & Close" to save the Security role "Business Central CDS Integration" with this extra privilege. Going forward, we have made a fix so that this privilege is always a part of "Business Central CDS Integration", for new installations.
Note: if you are using OAuth2 authentication, so your integration user is the auto-generated user with e-mail. If you have some custom security roles on the user you should assign them to the user with e-mail (name "Business Central Integration").