Skip to main content

Notifications

Announcements

No record found.

Dynamics 365 Community / Forums / Sales forum / "Product must hav...
Sales forum
Answered

"Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)

Posted on by 40

Hello Community

In my sandbox "Sales Hub" instance, all of a sudden i am getting an error when creating a new Product

"Product must have company filled"  (Business Process error)

As per my business users they have been creating Products without populating "Company" field and now this new behavior.

I looked into the Product entity and i see that:

Company field is optional,  there are no Business rules associated with Company Field.
Company field is part of key "Product Key"  and the properties of this key is not editable. So probably this out-of-box key and may not be causing the issue.
Where else could i troubleshoot this issue ?
Error log:
at Microsoft.Crm.Extensibility.OrganizationSdkServiceInternal.CreateInternal(Entity entity, InvocationContext invocationContext, CallerOriginToken callerOriginToken, WebServiceType serviceType, Boolean checkAdminMode, Dictionary`2 optionalParameters)
at Microsoft.Crm.Extensibility.OData.CrmODataExecutionContext.CreateOrganizationResponse(Entity entity)
at Microsoft.Crm.Extensibility.OData.CrmODataServiceDataProvider.CreateEdmEntity(CrmODataExecutionContext context, String edmEntityName, EdmEntityObject entityObject, Boolean isUpsert)
at Microsoft.Crm.Extensibility.OData.EntityController.PostEntitySetImplementation(String& entitySetName, EdmEntityObject entityObject)
at Microsoft.Crm.Extensibility.OData.CrmODataUtilities.<>c__DisplayClass10_0`2.<InvokeActionAndLogMetric>b__0()
at Microsoft.PowerApps.CoreFramework.ActivityLoggerExtensions.Execute[TResult](ILogger logger, EventId eventId, ActivityType activityType, Func`1 func, IEnumerable`1 additionalCustomProperties)
at Microsoft.Xrm.Telemetry.XrmTelemetryExtensions.Execute[TResult](ILogger logger, XrmTelemetryActivityType activityType, Func`1 func)
at lambda_method(Closure , Object , Object[] )
at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.<>c__DisplayClass10.<GetExecutor>b__9(Object instance, Object[] methodParameters)
at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ExecuteAsync(HttpControllerContext controllerContext, IDictionary`2 arguments, CancellationToken cancellationToken)
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Web.Http.Controllers.ApiControllerActionInvoker.<InvokeActionAsyncCore>d__0.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Web.Http.Controllers.ActionFilterResult.<ExecuteAsync>d__2.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Web.Http.Dispatcher.HttpControllerDispatcher.<SendAsync>d__1.MoveNext()
Activity Id: 5c52e479-70bd-40ac-8b39-28399538695c

Regards

Sartham

  • PB-30041459-0 Profile Picture
    PB-30041459-0 2 on at
    "Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)
    I am experiencing the same problem. Although I don't even use a Company table in my solution. Please let me know how to solve the issue. I am using the Sales Professional app. 
  • AmandaHK Profile Picture
    AmandaHK 5 on at
    RE: "Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)

    Hi, G286

    Could you describe a bit detailed of how to remove the related solutions?

    Appreciated!

    Regards,

    Amanda

  • G286 Profile Picture
    G286 30 on at
    RE: "Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)

    Now resolved. Solutions relating to Finance & Operations is where the Company field was introduced alongside field service.

    Removing these solutions (5 in total) and the field from the form has resolved the issue.

  • G286 Profile Picture
    G286 30 on at
    RE: "Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)

    Hi Sartham,

    Did you manage to resolve this issue?

    I am encountering the the same problem and also have field service installed so it is likely related.

  • Suggested answer
    RE: "Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)

    So does my environment--there is no company relationship with product and no alternate keys.

    I don't believe a key requires all values to be filled in.

    The "must have company filled" does not sound like a standard error message to me. I've never seen a standard system error use that term "filled." Sounds like maybe somebody created a plugin or some other kind of process to throw an error.

  • sartham Profile Picture
    sartham 40 on at
    RE: "Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)

    Hi Joel

    thank you for the response.

    i am not sure what could have added Company lookup field.

    as an FYI...We have Field Service app too.

    does every field in a Key for an entity become mandatory while creating a record ?

    on Product entity what else could i look for, that would cause this behaviour.

    regards

    Sartham

  • Suggested answer
    RE: "Product must have company filled" Error message when creating a new Product in sales Hub (Business Process error)

    Is the company lookup on the product a custom relationship? I don't see the company field on my product entity. Did someone add it as an alternate key? I checked in my environment and there is no Company lookup and no alternate keys for product, so my hunch is that someone created an alternate key or some other constraint on the product entity.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,459 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,783 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans