Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics AX forum
Unanswered

The type or namespace name 'EPFormAction' could not be found (are you missing a using directive or an assembly reference?)

Posted on by 1,146

Hi All,

all default components on EP does not open on throws below error, custom pages open normally.

 The type or namespace name 'EPFormAction' could not be found (are you missing a using directive or an assembly reference?) 

when trying to deploy or import page from AOT , it throws below error

server was unable to process request start index can not be larger than length of the string.

i did full Compile\CIL\DBsynch with same error, redeployed the portal with same error

any one can advise please?

Categories:
  • MDeeb Profile Picture
    MDeeb 1,146 on at
    RE: The type or namespace name 'EPFormAction' could not be found (are you missing a using directive or an assembly reference?)

    Thanks Martin,

    actually we have added the proxy and tried to deploy but still the same error since the proxy does not contain the "DirPersonUser" element mentioned in the error, however I have tried to add purchReqPoxy where the element couldn't be found as well as EPApplicationProxies1 and the same error appear. furthermore, more error appear(on a standart element where no customization has ever taken place). so I couldn't actually find a clue why a lot of element are being missing. I have also gone to test env where the Form is working and tried to open the PurchReqCreate from the VS data tools and deploy it and it gave the same error that appears on production so it seams strange that both env having the same error but one is working and the other is not.

    Thank you

  • Martin Dráb Profile Picture
    Martin Dráb 225,610 Super User on at
    RE: The type or namespace name 'EPFormAction' could not be found (are you missing a using directive or an assembly reference?)

    This error message suggests that there isn't a proxy for the X++ type. Checkout out what AX 2012 documentation says about Proxies.

  • MDeeb Profile Picture
    MDeeb 1,146 on at
    RE: The type or namespace name 'EPFormAction' could not be found (are you missing a using directive or an assembly reference?)

    4666.Capture.PNG

    Thanks a lot Martin,

    actually it was working perfectly for the past three years, one of our developers has deployed from system administration and since then production EP is down. with below attached error on every default page, i tried to redeploy the EP from media after i removed it , it deployed successfully but same error while browsing.

    Compile and CIL is successfull, i even deleted the XPPil files

    Thank you,

  • Martin Dráb Profile Picture
    Martin Dráb 225,610 Super User on at
    RE: The type or namespace name 'EPFormAction' could not be found (are you missing a using directive or an assembly reference?)

    I guess that you're talking about AX 2012; I'll change the version tag accordingly.

    Please give us some context of your problem. Is it a clean installation that never worked, or did it work before and it stopped? If so, what has changed?

    Which of the three processes (full Compile\CIL\DBsynch) threw the error? Don't bother to run the application application if it doesn't even compile - you'll need to solve compilation error first.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,995 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,610 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans