web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Microsoft Dynamics AX (Archived)

Script [Pre Configured VM] failed execution against VM

(1) ShareShare
ReportReport
Posted on by

Hi Guys,

I'm facing challenge in deployment of AX 2012 R3 on Azure with LCS in High Availability mode, Once witness is prepared, I'm getting error of Script [Pre Configured VM] failed execution against VM on First SQL VM.

----

[2015-12-24 06:08:40] Creating smoke test user as sysadmin
[2015-12-24 06:08:40] Microsoft.SqlServer.Management.PowerShell.SqlPowerShellSqlExecutionException: Incorrect syntax near '-'. ---> System.Data.SqlClient.SqlException: Incorrect syntax near '-'.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
   at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
   at System.Data.SqlClient.SqlDataReader.TryConsumeMetaData()
   at System.Data.SqlClient.SqlDataReader.get_MetaData()
   at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
   at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds)
   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)
   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)
   at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)
   at System.Data.SqlClient.SqlCommand.ExecuteReader()
   at Microsoft.SqlServer.Management.PowerShell.ExecutionProcessor.ExecuteBatch(String batch)
   --- End of inner exception stack trace --- : At line:198 char:3
+         Invoke-SqlCmd -Query "GRANT VIEW SERVER STATE TO $smoketestuser" -ServerInstan ...

Unable to find why this error is coming.

More details.

I'm using existing domain, I'm only deploying SQL and AOS Servers with HA.

*This post is locked for comments

  • Community Member Profile Picture
    on at

    Hi Farook i'm getting the exact same as you any clues so far?

  • Community Member Profile Picture
    on at

    I wonder if you had a dash or special character in the installer account username?

  • Community Member Profile Picture
    on at

    Hi

    Yes, Service Account has "-" in account login name. "-" this is creating a issue?

  • Community Member Profile Picture
    on at

    try checking Service Account and do check that your sending proper Service Account crendientilas.

    > if your doing integration please check IIS log file for error.

  • Community Member Profile Picture
    on at

    Hi Farook,

    have you solved your issue with the LCS deployment?
    I have exactly the same issue with the deployment of my AX 2012 R3 HA environment.

    Regards David

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the August Top 10 Community Leaders

These are the community rock stars!

Leaderboard > 🔒一 Microsoft Dynamics AX (Archived)

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans