Skip to main content
Microsoft Dynamics NAV forum
Suggested answer

Message processor error on NAV VT100 Plugin

editSubscribe (1) ShareShare
ReportReport
Posted on by 28
Hi there, I'm trying to test the ADCS functionality in Dynamics NAV 2018 running on windows server 2012 r2 for which I've installed and configured the VT100 plugin and exposed the ADCS Codeunit on port 7047 as mentioned in this blog. Firewall has been disabled and I'm able to run this web service.
 
On the other hand, port 6666 has been enabled on this server, however when trying to connect locally, Telnet client throws the following error message;
 
 
 
Another error message reads - /Requeue of message failed after sequential message processor errors./ When I tried to connect remotely, Telnet client fails to establish the connection to both the domain address and public IP.
 
 
Is anyone running into the same problem? Not sure if I'm missing something here but any help would be appreciated!
 
Thank you,
Daniel
 
Attachments
  • Message processor error on NAV VT100 Plugin
    Thank you so much for the link. I was also facing the same issue and I am looking for the solution online and I am glad I found your post where I found my answer. When I was searching for it online, I also discovered the https://academized.com/pay-for-thesis website link where I found an essay writer whom I can pay for my thesis assignment. Now, I won't take too much time to write my thesis assignments because I can simply take help from the given link.
  • DannyAL Profile Picture
    DannyAL 28 on at
    Message processor error on NAV VT100 Plugin
    Never mind Gerardo, I figured out my mistake. When using basic auth, the connection string in the .exe must include the username and password attributes if using log on as network service (CredentialType: NavUserPassword). Also, SSL must be enabled on the NAV instance and the certificate hash must be added to port 7047 using the netsh command.
     
    Sadly, the self-signed certificate did not work as the event log returned message - "Could not establish trust relationship for the SSL/TLS secure channel with authority '127.0.0.1:7047'". Hence, a valid domain certificate is required by the plugin.
     
    Wish there was a way to bypass this validation check! 😥
     
     
  • DannyAL Profile Picture
    DannyAL 28 on at
    Message processor error on NAV VT100 Plugin
    Thank you Gerardo for the prompt reply. I went through the links but still no luck. I tried all combinations like switching from localhost to the public IP in the plugin .exe file or switching from local account to windows account in the service properties but still the same error.
     
    However, I came across the following error in my event logs with regards to unauthorized HTTP request. No idea how to resolve this. Do you have any solution?
     
    ​​​​​​​
     
    Best Regards,
    Daniel
     
  • Suggested answer
    gdrenteria Profile Picture
    gdrenteria 2,788 Super User on at
    Message processor error on NAV VT100 Plugin

Helpful resources

Quick Links

New Blog Features Released!

Check out the new community blog features for viewers and authors…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,166 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,703 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Featured topics

Product updates

Dynamics 365 release plans