Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics CRM forum
Suggested answer

Ribbon Workbench doesn't open solution

Posted on by 2
Hello,
 
When I'm trying open the solution /account/ this error appears, it stop loading and I can't figure it out why. I try create a new solution but doesn't work
 
RBW:3.1.647.1.9,CRM:9.2.24042.196
System.Exception: EntityRibbons is null
em RWB2016.Plugins.RibbonCustomisationsPlugin.GetRibbonXml(LocalPluginContext localContext, String entityLogicalName, Boolean unzip)
em RWB2016.Plugins.RibbonCustomisationsPlugin.GetRibbonJSON(LocalPluginContext localContext, ITracingService trace, String inputData)
em SparkleXrm.Plugins.Plugin.Execute(IServiceProvider serviceProvider)
Stack Trace:
Error:
at Xrm_Sdk_OrganizationServiceProxy$endExecute (:50205/WebResources/js/ClientUI.js:4677:13)
at Anonymous function (:50205/WebResources/js/ClientUI.js:19533:5)
at delegate (:50205/WebResources/js/ClientUI.js:2227:13)
at $1_0 (:50205/WebResources/js/ClientUI.js:19637:70)
Trace:
em SparkleXrm.Plugins.Plugin.Execute(IServiceProvider serviceProvider)
em RibbonWorkbenchAppHost.SparkleXrmBridge.ProcessExecute(String soapRequest, NameTable nt, XmlNamespaceManager prefixes)
em RibbonWorkbenchAppHost.SparkleXrmBridge.Process(String soapRequest, String action, NameTable nt, XmlNamespaceManager prefixes, Action`1 callback)
  • Inesrfo Profile Picture
    Inesrfo 2 on at
    Ribbon Workbench doesn't open solution
     
    yes, but i can try again, and in the xmltoolbox should work and it doesnt
    yes and in a diferent network and computor and nothing...
    yes, and it worked for a long time, it just stopped working and i cant find a reason...
  • Inesrfo Profile Picture
    Inesrfo 2 on at
    Ribbon Workbench doesn't open solution
    Bipin D365 I tried many times using  xrmtoolbox and still now working :(
  • Suggested answer
    Bipin D365 Profile Picture
    Bipin D365 28,958 Super User on at
    Ribbon Workbench doesn't open solution
    Hi,
     
    Could you please try using Ribbon workbench in xrmtoolbox to see if it works?
     
    Make sure you are only adding Entity and no components in your solution which you are using from Ribbon workbench.
  • Suggested answer
    Dengliang Li Profile Picture
    Dengliang Li Microsoft Employee on at
    Ribbon Workbench doesn't open solution
    Hi,
     
    Have you tried uninstalling and then installing the latest version of RibbonWorkbench?
    Have you tried loading it in a different browser and in privacy mode?
    Did you just add the account entity without including any metadata?
     
    If you are just adding new buttons and not making changes to the system buttons, then you can use the New Command Designer.
     
    Best Regards,
    Dengliang Li
     

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,696 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,490 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans