Skip to main content
Business Central forum
Answered

Which version of GP you should be in to use migration tools in Business Central

editSubscribe (0) ShareShare
ReportReport
Posted on by 132

Hi, our company is planning to migrate to Business Central from GP, we are version 2015 R2 of GP. Planning to upgrade GP to 2018 so that we can use data migration tools.

Which version of GP18 we should move to?

and any other thing we should keep in mind.

Categories:
Attachments
  • Suggested answer
    Smehra33 Profile Picture
    Smehra33 132 on at
    RE: Which version of GP you should be in to use migration tools in Business Central

    Thank you for sharing all the resources with me. Yes, I have read that we can migrate from 2015 or later. My only concern is that I read somewhere Migration tool can only be used with GP2018 or later and SQL2016. Thank you again. I appreciate your guidance.

  • Suggested answer
    YUN ZHU Profile Picture
    YUN ZHU 59,978 Super User on at
    RE: Which version of GP you should be in to use migration tools in Business Central

    Hi, just adding some info. It's also mentioned in the MS Docs below.

    https://learn.microsoft.com/en-us/dynamics365/business-central/dev-itpro/administration/migrate-data

    Dynamics GP 2015 and later versions

    pastedimage1670890440971v1.png

    Hope this helps.

    Thanks.

    ZHU

  • Verified answer
    Andrea Melroe Profile Picture
    Andrea Melroe 3,437 on at
    RE: Which version of GP you should be in to use migration tools in Business Central

    Hi Smehra33,

    You can migrate GP 2015 and later versions to Business Central. There is not a specific version of GP 2018 I'd recommend you upgrade to prior to migrating (if you upgrade it really doesn't matter which version of 2018 you upgrade to - you can migrate from any of them).

    **Very important: You must be using SQL Server 2016 or above to migrate.

    Here’s a link to our documentation that talks about which products and versions are supported:

    https://learn.microsoft.com/en-us/dynamics365/business-central/dev-itpro/administration/faq-migrate-data#which-products-and-versions-are-supported

    Here’s a link to a blog that talks about the SQL requirements and when those changed:

    SQL compatibility changes when migrating to Business Central - Dynamics 365 Business Central Community

    Also, here’s a link to a great GP to BC Migration blog series that contains a plethora of helpful information (I suggest you read through this information prior to migrating):

    Landing Page for GP to BC Migration Information - Dynamics 365 Business Central Community

    I hope this helps!

  • Smehra33 Profile Picture
    Smehra33 132 on at
    RE: Which version of GP you should be in to use migration tools in Business Central

    Our current version of GP is 14.00.0983

  • Harsh Patel Profile Picture
    Harsh Patel 130 on at
    RE: Which version of GP you should be in to use migration tools in Business Central

    Hey, what is your current full GP version? For example: 14.00.0898, etc.

Helpful resources

Quick Links

New Blog Features Released!

Check out the new community blog features for viewers and authors…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,080 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,601 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Featured topics

Product updates

Dynamics 365 release plans