Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics AX forum
Answered

Strange Behaviour of Ax

Posted on by Microsoft Employee

Hi all

 I am stuck in a very strange scenario. My Sql Drive was full in the morning so i shrinked it & put my system into Full Compilation after it. As just half hour ago when I tried to view the Compilation Log , the client crashed several times. I opened Ax by Debugging through visual studio & found strange things. Following is  the screenshot:-

I can see 2 new modules i.e Fixed asset(russia) & Payroll (Russia).

I am not able to open option form & run compilation.

In Case of file which usually is in en-us,
 the text is "MMANDBA".

 

The version is AX 2012 R3 & localisation is indian.

 

 

tst.pngworkspace.pngage-link.pngtst.png

 

please help.

  • SU-22040800-0 Profile Picture
    SU-22040800-0 2,389 on at
    RE: Strange Behaviour of Ax

    I deleted all the .UAC and .KTI files from the C:\Users\<user>\AppData\Local folder, and restarted AX

  • Verified answer
    RE: Strange Behaviour of Ax

    As indicated by David Orr, " Clearing all of his usage did not fix it, but deleting all of the .auc files and other files in the Users/username/AppData/Local directory fixed the problem for him. We are not sure whether doing this in the first place would have meant we didn't have to reinstall everything."

    In our situation (as an example of not reinstalling everything)...this solution worked for us, as I believe it was a client-side APPDATA "cache" issue specifically. Once I cleared the files indicated above (all files in that directory), the client worked as expected and labels/errors resolved.

    I believe the root cause is one of the old .KTI files (having compared a profile that worked vs. did not work) was stuck in there (along with the updated one)...nonetheless, deleting all the old files resolved in our case.

  • Douglas Noel Profile Picture
    Douglas Noel 3,905 on at
    RE: Strange Behaviour of Ax

    Hi,

    can confirm having had similar issues R3CU8 with SQL2k12, even completely vanished modules. Only restoring worked for me.

    Regards

    Douglas

  • Suggested answer
    Umesh Pandit Profile Picture
    Umesh Pandit 9,102 User Group Leader on at
    RE: Strange Behaviour of Ax

    Same happened with me on AX 2012 R3 CU8, SQL 2014, What we did was restored the a day old backup, followed by clearing the auc files and then start of the aos, we did full compile via command and then full-data sync and full cil.

  • Verified answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Strange Behaviour of Ax

    Hi Deepak,

    We have had the same strange problems twice in our new R3 installation. This was after we had spent some time setting up parameters and the GL, and the only thing we could find to fix it was to completely reinstall AX. The second time we were able to restore the database and get our setup back.

    I have just got our system fixed again and everything looked good, but my colleague still had the strange labels and errors regarding SysUserInfo when trying to open various parameter forms. Since it worked for me and not for him, we figured it must be something to do with usage data or caching. Clearing all of his usage did not fix it, but deleting all of the .auc files and other files in the Users/username/AppData/Local directory fixed the problem for him. We are not sure whether doing this in the first place would have meant we didn't have to reinstall everything.

    We did not have a problem with the database running out of space. I'd suggest you try clearing the AppData files and see if that works.

    Regards,

    David Orr

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Strange Behaviour of Ax

    Hi Andre

    Yes I took the back up of databases  before Shrinking them. I also mounted a new drive so that I can change the path of databases in order to manage the disk space.

    But i did not restore any new database on the previous one. I am going to update in the forum after the Full CIL will be finished. That will probably give the clear picture.

  • André Arnaud de Calavon Profile Picture
    André Arnaud de Cal... 287,995 Super User on at
    RE: Strange Behaviour of Ax

    Hi Deepak,

    Can you tell more about how you solved the issue with SQL server? Did you create a backup and then shrunk the database? Are you sure it is the same database or did you restore an older or other database?

    If names of classes are changed, then probably you now have another model store. At least that is what it looks like.

    Easy saying, but it happens too often: Monitor the systems and don't let it run out of disk space. I see it happening about 2-3 times a year at customers.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Strange Behaviour of Ax

    Thanks for your reply Andre.

    I started the X++ compilation & after that I faced frequent client crashes.But getting those 2 additional modules i.e   Fixed asset(Russia) & Payroll (Russia) all of a sudden really made me curious to know the reason & solution of this bizarre issue.

    I have observed that names of few classes have also been changed. I have started X++ compilation through AX build again but I am really seeking for a quick resolution.

    I tried to show those 2 Additional modules along with few different names of menus & file.

    Thanks for your help & hope you will help me further in order to solve this.

  • André Arnaud de Calavon Profile Picture
    André Arnaud de Cal... 287,995 Super User on at
    RE: Strange Behaviour of Ax

    Hi Deepak,

    Had you started the full compilation in the AX client? Was this a CIL or x++ compilation? Did you also have restarted the AOS after fixing the SQL database?

    You can try to use the axbuild command to compile your environment from the command prompt and see if this solves your issue. Then also perform a full CIL compilation.

    The screenshots are too small to read. The only thing I can recognize it that you have to activate your Windows operating system ;)

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,995 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,610 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans