web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Small and medium business | Business Central, N...
Suggested Answer

GP to Business Central migration - Failed to prepare the systems for replication

(0) ShareShare
ReportReport
Posted on by

I am working through a GP to BC migration and testing it, but I can't connect. I have the integration service setup, but when I try and connect, I am given this message:
The call to prepare servers failed. Run id='96546fb9-bf15-4d5b-8866-34301cef3b7f', Name='msft1a6720t63301344_GP_Preparation', ErrorMessage='Operation on target CheckCompatibilityLevel failed: ErrorCode=InvalidParameter,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=The value of the property '' is invalid: 'Keyword not supported: ': server'.'.,Source=,''Type=System.ArgumentException,Message=Keyword not supported: ': server'.,Source=System.Data,''

Below is my SQL connection String:
: Server=EU-GP\GP;Database=ENAB;User ID=username;Password=ActualPassword;

I also tried

Server=EU-GP\GP;Database=ENAB;User ID=username;Password=ActualPassword;

Any ideas?

Thanks,

Kevin

  • Suggested answer
    Marco Mels Profile Picture
    Microsoft Employee on at

    Hello,

    The connection string is wrong. It should be in correct format. E.g.:

    For example, Server=MyServer\BCDEMO;Database=BC180;UID=MySQLAccount;PWD=MyPassWord;, if you're migrating from Business Central on-premises, version 18. For more information, see the SQL Server blog.

    The following snippets illustrate a couple of connection strings with different formats:

    Server={Server Name\Instance Name};Initial Catalog={Database Name};UserID={SQL Authenticated UserName};Password={SQL Authenticated Password};

    Server={Server Name\Instance Name};Database={Database Name};User Id={SQL Server Authenticated UserName};Password={SQL Server Authenticated Password};

    Important

    In the second connection string format, don't forget to add the space in User Id parameter as it's mandatory and can throw an error if it's missing.

    Hope it helps (the below applies to GP as well).

  • Gavin Profile Picture
    2,510 on at

    Hi,

    To add to this, I also noticed the text "CheckCompatibilityLevel" in the error as per below:

    pastedimage1668758916203v1.png

    According to this MS article you have to ensure the databases are set to a compatibility level of 130 or higher. (Migrate on-premises data to the cloud - Business Central | Microsoft Learn)

    pastedimage1668759040389v2.png

    Therefore, it might also be worth checking this.

    Hope this helps.

    Thanks

    Gavin

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the July Top 10 Community Leaders

These are the community rock stars!

Leaderboard > Small and medium business | Business Central, NAV, RMS

#1
OussamaSabbouh Profile Picture

OussamaSabbouh 710 Super User 2026 Season 2

#2
YUN ZHU Profile Picture

YUN ZHU 387 Super User 2026 Season 2

#3
AndrewThomas81 Profile Picture

AndrewThomas81 385 Super User 2026 Season 2

Last 30 days Overall leaderboard

Featured topics

Microsoft Training Manuals

Product updates

Dynamics 365 release plans