Skip to main content
Business Central forum
Suggested answer

GP to Business Central migration - Failed to prepare the systems for replication

editSubscribe (0) ShareShare
Posted on by

I am working through a GP to BC migration and testing it, but I can't connect. I have the integration service setup, but when I try and connect, I am given this message:
The call to prepare servers failed. Run id='96546fb9-bf15-4d5b-8866-34301cef3b7f', Name='msft1a6720t63301344_GP_Preparation', ErrorMessage='Operation on target CheckCompatibilityLevel failed: ErrorCode=InvalidParameter,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=The value of the property '' is invalid: 'Keyword not supported: ': server'.'.,Source=,''Type=System.ArgumentException,Message=Keyword not supported: ': server'.,Source=System.Data,''

Below is my SQL connection String:
: Server=EU-GP\GP;Database=ENAB;User ID=username;Password=ActualPassword;

I also tried

Server=EU-GP\GP;Database=ENAB;User ID=username;Password=ActualPassword;

Any ideas?



  • Gavin Profile Picture
    Gavin 2,331 on at
    RE: GP to Business Central migration - Failed to prepare the systems for replication


    To add to this, I also noticed the text "CheckCompatibilityLevel" in the error as per below:


    According to this MS article you have to ensure the databases are set to a compatibility level of 130 or higher. (Migrate on-premises data to the cloud - Business Central | Microsoft Learn)


    Therefore, it might also be worth checking this.

    Hope this helps.



  • Suggested answer
    Marco Mels Profile Picture
    Marco Mels on at
    RE: GP to Business Central migration - Failed to prepare the systems for replication


    The connection string is wrong. It should be in correct format. E.g.:

    For example, Server=MyServer\BCDEMO;Database=BC180;UID=MySQLAccount;PWD=MyPassWord;, if you're migrating from Business Central on-premises, version 18. For more information, see the SQL Server blog.

    The following snippets illustrate a couple of connection strings with different formats:

    Server={Server Name\Instance Name};Initial Catalog={Database Name};UserID={SQL Authenticated UserName};Password={SQL Authenticated Password};

    Server={Server Name\Instance Name};Database={Database Name};User Id={SQL Server Authenticated UserName};Password={SQL Server Authenticated Password};


    In the second connection string format, don't forget to add the space in User Id parameter as it's mandatory and can throw an error if it's missing.

    Hope it helps (the below applies to GP as well).

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…


Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,066 Super User

Martin Dráb Profile Picture

Martin Dráb 222,585 Super User

nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans