Skip to main content

Notifications

Announcements

No record found.

Business Central forum
Suggested answer

Unauthorized The credentials provided are incorrect

Posted on by 4

I was running Postman to try out the Trail Business Central API's. I following the instruction (Access Business Central API) and just wanted to display the metadata for my Business Central account.

I used the following endpoint: https:/api.businesscentral.dynamics.com/v2.0/D365Env/api/v2.0

D365Env is a sandbox I created. I have read many post and have tried adding difference combinations of an APP in Azure but no luck. Keep getting same error. Does anything need to be done in BC that I might have missed.

but get the following error: /Unauthorized The credentials provided are incorrect /

I did get a valid token using my Azure credentials clientID and client_secret.

I also did add API's and API permissions.

Thanks for your help 

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,459 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,783 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans