Skip to main content

Notifications

Microsoft Dynamics AX forum
Answered

AX2012 R2 CU7 AOS Crashes after Report Deployment

Posted on by 2,695

I have a new installation of AX2012 R2 CU7 and just deployed the standard reports yesterday.  I restarted the AOS today, and now the AOS crashes any time a client attempts to log in.  I have tried two of different client installations and both fail.  The event log on the AOS displays an error 1000 saying that the AX32Serv .exe application faulted, but the faulting module is UNKNOWN.  I have reviewed the Windows Error Report and find that every time the server fails the same module was loaded last.

 LoadedModule[412]=C:\Users\AXADMIN\AppData\Local\assembly\dl3\AYOBTLBM.9EL\RRMTBO28.2DO\fe595353\3f6a60c6_9423cf01\QRCode.DLL

I have checked the Sharepoint permissions (the report server is in Integrated mode), I have deleted the cache files on the client, the VSAssemblies, and the whole assembly folder referenced above (AYOBTLBM.9EL).  They get replaced when the client starts, but then the AOS crashes.

Does anyone have any idea how to resolve this?

Thanks!

LJ

  • lispyj Profile Picture
    lispyj 2,695 on at
    RE: AX2012 R2 CU7 AOS Crashes after Report Deployment

    I tried to use AXBUILD, but two different attempts crashed.  I uninstalled just the AOS and reporting services, and, after reinstalling, I am now able to open clients without error.  In addition to uninstalling, I deleted the Server folder inside the Dynamics folder, plus all client cache files.  I also deleted and recreated the Sharepoint report library.

    Now, I just need to redeploy reports to see if it happens again!

    Thanks!

  • fsilva-jr Profile Picture
    fsilva-jr 20 on at
    RE: AX2012 R2 CU7 AOS Crashes after Report Deployment

    This is true!

    LYSPJ, you can try it and tell us if it worked for you!

  • Suggested answer
    Denis Macchinetti Profile Picture
    Denis Macchinetti 16,444 on at
    RE: AX2012 R2 CU7 AOS Crashes after Report Deployment

    Hi

    Francisco, you are right.

    But before to remove AOS and Client, you can try to run the Full Compilation with the AxBuild.exe utility.

    technet.microsoft.com/.../dn529055.aspx

    Regards

  • Verified answer
    fsilva-jr Profile Picture
    fsilva-jr 20 on at
    RE: AX2012 R2 CU7 AOS Crashes after Report Deployment

    So, if your client stop the AOS server you wont be able to compile or sincronize...

    Think about to remove the entire AOS and Client componentes. Backup your Databases before!!!

    After to backup the databases and remove AOS and Client componentes, delete all the AX folders from your Server and than reinstall the AOS and Client again...

    "maybe" (i hope so) it helps you!

  • Suggested answer
    Denis Macchinetti Profile Picture
    Denis Macchinetti 16,444 on at
    RE: AX2012 R2 CU7 AOS Crashes after Report Deployment

    Hi

    I suggest you to Compile Environment and also launch a Full Cil.

    Regards

Helpful resources

Quick Links

Community Spotlight of the Month

Kudos to Mohamed Amine Mahmoudi!

Blog subscriptions now enabled!

Follow your favorite blogs

TechTalk: How Dataverse and Microsoft Fabric powers ...

Explore the latest advancements in data export and integration within ...

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,682 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,000 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,146

Featured topics

Product updates

Dynamics 365 release plans