Skip to main content

Notifications

Microsoft Dynamics AX forum
Unanswered

Configure AX Web service

Posted on by Microsoft Employee

Hi,

I have a problem with a inbound port that i seems not able to configure. I'm in AX 2012 R2.

On my development machine (Windows 7), with the AOS and the IIS, when I click on Configure, I have the question message that said that the assembly ...TEMP\Microsoft.Dynamics.IntegrationFramework.webservice.Process.dll contains unsafe code. The SvcConfigEditor will execute a part of the code. If I say no, I have a warning that say that the type Microsoft.Dynamics.Ax.Services.Host.ClientEndPointBehaviorExtension has not been loaded...

If I say yes the Microsoft Service Configuration Editor open and it work perfectly and finally, the web service works.

 

BUT on a Windows Server 2008 for our clients services with the AOS and the IIS, when I click on Configure, I don't have any questions or warnings, but when the Microsoft Service Configuration Editor  open, some pieces seems missing like the clientEndPointBehavior and no default endpoint is created in the Services Folder.

I'd tried to create the missing part in the editor so an I can deploy. It work for the deployment but I can't make the web service working. It's like the web service can't reach the AOS.

 

If any of you have some ideas, I'll be very please. I'm a bit lost after one week of searching.

Thanks

 

 

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Configure AX Web service

    Yup! not supported. It's what they said in my ticket, but I don't kn ow if it's written anywhere else. That's wy we create a specific account that it's use transparently. That account is kept in the admin parameters of the calling program, but no end-user know it...

    In AX7, the AIF is not supposed to be there anymore so don't put too much effort.

  • Esther Mulijono Profile Picture
    Esther Mulijono 435 on at
    RE: Configure AX Web service

    Hi Pascal,

    Apparently I need to erase the unused tag at the call context in SOAPui like <dat:MessageId> tag.

    Now I can get HTTP/1.1 200 OK response but I'm still using Ntlm authentication.

    Is Microsoft really said that the anonymous authentication is not supported in AIF service from the CU6 and beyond? Because in my requirement, we need to provide the service without using any authentication.

    Is there any reference about that matter?

    Thank you very much.

    --

    Regards,

    Esther Mulijono

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Configure AX Web service

    We just follow the Microsoft recommendations at: technet.microsoft.com/.../gg731848.aspx

    If you can be more specific on your exact problem, maybe I can help you...

  • Esther Mulijono Profile Picture
    Esther Mulijono 435 on at
    RE: Configure AX Web service

    Hi Pascal,

    I'm facing the same problem.

    May I know how you configure the web service in IIS and in the inbound port AX?

    Thank you in advance.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Configure AX Web service

    No, sorry. We did'nt have that kind of problem.

    On our developper workstation, when we configure the Entry point web service, the clientEndpointBehavior was already present. But on a SErver, the DefaultEndpoint and the clientEndpointBehavior was not already there so we have to create it, but we did it directly by the web.config editor by the configure button in the AX client.

    The only thing that we have to change directly in web.config was apparently related to a bug that is fix in the CU7. We had to change the address of the endpoint to put the IP adress instead of the host name.

    I don't know what I can say further to help you, but fell free to ask. It will be my pleasure to try to help you.

  • Geert Van Reusel Profile Picture
    Geert Van Reusel 10 on at
    RE: Configure AX Web service

    Hi Pascal,

    I also followed the recommendations of Microsoft, but I get some errors in the web.config file. At first, he tells that there is a missing node with <customerrors mode = "off">. I can add that manually in the file. The next error is that there is no endpoint behavior named "clientEndPointBehavior", although is it declared in the file. Did you experience the same problems and do you have a solution ?

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Configure AX Web service

    Yes, we are now following the recommendations of Microsoft and we are now using the bindingConfiguration "basicHttpBindingWithWindowsAuth". So we have created a Activie directory user and imported it in AX that is used uniquely for the web service.

  • Geert Van Reusel Profile Picture
    Geert Van Reusel 10 on at
    RE: Configure AX Web service

    Do you have a solution at this moment ? We are facing the same problem after upgrading to CU7 over the weekend.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Configure AX Web service

    Yes, we were using a claim user created in AX.

  • Roedkjaer Profile Picture
    Roedkjaer 65 on at
    RE: Configure AX Web service

    Hi, some thoughts.

    Did you verify that the submitting user is a valid and authenticated AX user? Webservices use the windows identity of the submitting user. Filebased services use file owner as submitting user.

    Did you try changing "LogonAsUser" in the callContext object?

Helpful resources

Quick Links

Community Spotlight of the Month

Kudos to Mohamed Amine Mahmoudi!

Blog subscriptions now enabled!

Follow your favorite blogs

TechTalk: How Dataverse and Microsoft Fabric powers ...

Explore the latest advancements in data export and integration within ...

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,682 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,000 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,146

Featured topics

Product updates

Dynamics 365 release plans