Skip to main content
Microsoft Dynamics GP forum
Unanswered

Management Reporter Error - Dimension Name

editSubscribe (0) ShareShare
ReportReport
Posted on by 22,645

I have a situation with Management Reporter in which I attempt to open a Tree Definition and I get a failure message - ParamterName=dimensionname

We have been using MR for some time and of course I had to have access to it at some time, as I did create the base Tree features.  Now I am going back to work on more details in the TREE

and I get this error ….

Any suggestions?

Categories:
  • olegvi Profile Picture
    olegvi 769 on at
    RE: Management Reporter Error - Dimension Name

    I had the same error popping up when clicking on the Row Definition. 

    The issue actually came from the TEST company where I was testing AA the day before. The error was logged in Configuration Console of MR, under Data Mart Integration logs.

    Restoring the TEST from Prod and rebuilding MR fixed it for me.

  • Greg Byer Profile Picture
    Greg Byer 2,586 on at
    RE: Management Reporter Error - Dimension Name

    Hi Bill,

    This error can happen if you have a dimension name that is the same in more than one segment.  Since it only happens when using the -AA company, you'll want to check that the AA dimensions are unique and not the same as one of the GP segments.

    In GP, go to Cards > Financial > Analytical Accounting > Transaction Dimensions.

    Click the lookup button and note the names of the dimensions.

    Go to Tools > Setup > Company > Account Format and check to see if any of the dimensions match the segment name.

  • Bill Campbell Profile Picture
    Bill Campbell 22,645 on at
    RE: Management Reporter Error - Dimension Name

    Additional Update to this.  Yesterday I thought that if I was logged into the system as the Domain / Local admin user that the problem stopped.  This is not correct.

    If my base / default company is not the COMP-AA but only COMP then I do not get the error and can open the TREE and make the changes or review as needed.

    This true at the Company level as well as in the TREE when choosing the COMPANY in Column A  - as long as I do not enter COMP-AA not a problem - soon as I choose COMP-AA then the system generates the Parameter Name: dimensionname message and processes a 'problem has caused the program to stop working - choice then are DEBUG or CLOSE.

    From the Services Log in Management Reporter Configuration Console - I have extracted the following statement - 

    Parameter name: dimensionName Action:  Fault code: Sender IsSenderFault: True IsReceiverFault: False Reason:
    Parameter name: dimensionName
     Machine: PWISE-DYN

    This is the Warning message found in same Log window.

    2019-11-27T21:44:13.7156367Z:  Severity: Warning MessageTypes: General Text: Skipping account filter 51 for Unit: 73b711...Row Number: 20 Restricted: False AssemblyName: Microsoft.Dynamics.Performance.DataProvider.GeneralLedger.GP, Version=7.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 MachineName: PWISE-DYN PrincipalIdentityName:  WindowsIdentityName: ACCFCR\a.pcadmin ThreadId: 16 RelatedException:

    Trying to figure out what to do next.

  • Bill Campbell Profile Picture
    Bill Campbell 22,645 on at
    RE: Management Reporter Error - Dimension Name

    Just a quick update - this does not happen when login to the computer is local / domain admin.  Is there a security point I am missing?

    Thanks.

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,066 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,585 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans