I tried to configure SSL using a wildcard certificate and was not successful.  While the configuration console has a hostname field, it is grayed out for editing.  I wanted to use https://mr.domain.com:4713.  But instead, the configuration console insisted on configuring https://localservername:4713.  

I tried manually registering the cert using netsh.exe and editing MRServiceHost.settings.config, but I couldn't get it to work.