Question Status

Verified
SuperIT asked a question on 11 Sep 2017 3:00 PM

I am currently trying to upgrade from GP 10 with the latest service pack applied.  I installed GP 2013 and launched GP Utilities and I get this error:

"There is a problem ascertaining product version information.  GP utilities will now exit.  Please check the duinstall.log for more information."

I did that and here is what on there:

ailure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 258 does not support upgrading from version 10.0.775.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 309 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 1045 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 1235 does not support upgrading from version 10.0.777.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 1428 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 2150 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 3180 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 3258 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 3830 does not support upgrading from version 10.0.20.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 4421 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 258 does not support upgrading from version 10.0.775.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 309 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 1045 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 1235 does not support upgrading from version 10.0.777.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 1428 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 2150 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 3180 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 3258 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 3830 does not support upgrading from version 10.0.20.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 4421 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 258 does not support upgrading from version 10.0.775.
Failure encountered ON 9/8/2017 at 3:48:44 PM. Error: Product 309 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 1045 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 1235 does not support upgrading from version 10.0.777.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 1428 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 2150 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 3180 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 3258 does not support upgrading from version 10.0.774.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 3830 does not support upgrading from version 10.0.20.
Failure encountered ON 9/8/2017 at 3:48:45 PM. Error: Product 4421 does not support upgrading from version 10.0.774.

What am i doing wrong?

Reply
Richard Wheeler responded on 11 Sep 2017 4:07 PM

You need to upgrade your GP 10 to 10.00.1579. You are only on 10.00.0774. You can log onto CustomerSource to obtain this service pack.

Reply
Richard Wheeler responded on 11 Sep 2017 4:09 PM

mbs.microsoft.com/.../MDGP10_PreviousPatches

This will take you there. You can also use 10.00.1779.

Reply
Suggested Answer
Bill Campbell responded on 11 Sep 2017 4:10 PM

If you have installed the last service pack for GP10 - lets say it was the Year End for 2015 ( not that it was ) so when you install GP2013 you need to install the same or greater Service pack.

So if the base install of GP2013 is June 2013 - then you need to apply the Year End for 2015 for GP2013 to make them equal.

This is how I have been doing updates for the past number of years, there may be a better answer but I know for me that this works.

Keep in touch and let us know the out come of the work.

Reply
Bill Campbell responded on 11 Sep 2017 4:11 PM

As Richard ( typing faster than me ) pointed out - you may have it in the opposite direction as well - I did not consider that - but if that is the case the same principal holds.

Thanks for the point Ricard.

Reply
SuperIT responded on 11 Sep 2017 4:26 PM

Richard,

I applied service pack 5 for GP 10 which should've brought the version to 10.00.1881.00.  As a matter of fact when I launched programs and features it listed GP 10 as version 10.00.1881.00.  Am I suppose to apply all of the previous service packs first?

SuperIT

Reply
Richard Wheeler responded on 11 Sep 2017 5:02 PM

Sometimes certain service pack levels do not update. I know 1579 does because that is where I usually start. They tells me 1779 does. Can you start over and bring it back to 1579?

Reply
SuperIT responded on 11 Sep 2017 6:17 PM

I'll go ahead and get to 1779 before I install GP 2013.  Hopefully this works.  Thanks!

Reply
SuperIT responded on 12 Sep 2017 4:21 PM

Richard,

It didn't work.  For some reason even though it looks like it's converting the databases when I launch GP utilities it is not changeing the version to what it should be.  I am still getting the same error that the features that should've been updated is still at version 10.0.774 when it should be 10.0.1779.  Is there a hotfix that directly addresses this issue?  I am trying to download 1579 but the Microsoft file exchange system keeps telling me that an error has occurred and I'm not able to download anything.  Is it down right now?

SuperIT

Reply
Richard Wheeler responded on 12 Sep 2017 5:53 PM

Back in the old days it would do that and not show the correct version when you launched GP Utilities. Check your [DYNAMICS].[dbo].[DU000020] table. Keep trying to download 1579. That is what you need.

Reply
Suggested Answer
Bill Campbell responded on 12 Sep 2017 5:59 PM

Unless I have missed this completely - the file that you need is:

MicrosoftDynamicsGP-KB975705-v10-ENU.exe

Should be SP for GP 10 back in October 2010 if that helps.

Reply
Verified Answer
Leslie Vail responded on 12 Sep 2017 6:38 PM

I think the KB for 10.00.1779 is  KB2599501. I believe it is the 2011 US Payroll Year End Update. You can access the old GP 10 service packs here: https://mbs.microsoft.com/customersource/northamerica/GP/downloads/service-packs/MDGP10_PreviousPatches

Kind regards,

Leslie

Reply
Leslie Vail responded on 12 Sep 2017 7:06 PM

Hi,

I had a similar problem yesterday with a 2016 upgrade. I wasn't on the right build for the upgrade, it worked once I uninstalled the old build and reinstalled GP with the correct build in the Updates folder of the Installation Media. The DB_UPGRADE table in the Dynamics dictionary will show you where your build is now, and when you run GP Utilities you will see the build it's going to. The 1779 build should be displayed when you start to run GP Utilities. If it is not, I don't think you should proceed. You should also be able to upgrade to 2013 from a later build of GP 10, but GP 10.00,1779 is the minimum.

Kind regards,

Leslie

Reply
SuperIT responded on 13 Sep 2017 1:21 PM

how do i check that table to see if the version is correct?

Reply
SuperIT responded on 13 Sep 2017 2:24 PM

I was able to get past the error using KB2599501.  I am now able to upgrade to GP 2013 .  Thanks for your help.

Reply
SuperIT responded on 13 Sep 2017 2:26 PM

Thanks for the advise.  It worked.  I am now able to upgrade to GP 2013.  This is a test run.  

Reply
Verified Answer
Leslie Vail responded on 12 Sep 2017 6:38 PM

I think the KB for 10.00.1779 is  KB2599501. I believe it is the 2011 US Payroll Year End Update. You can access the old GP 10 service packs here: https://mbs.microsoft.com/customersource/northamerica/GP/downloads/service-packs/MDGP10_PreviousPatches

Kind regards,

Leslie

Reply
Suggested Answer
Bill Campbell responded on 11 Sep 2017 4:10 PM

If you have installed the last service pack for GP10 - lets say it was the Year End for 2015 ( not that it was ) so when you install GP2013 you need to install the same or greater Service pack.

So if the base install of GP2013 is June 2013 - then you need to apply the Year End for 2015 for GP2013 to make them equal.

This is how I have been doing updates for the past number of years, there may be a better answer but I know for me that this works.

Keep in touch and let us know the out come of the work.

Reply
Suggested Answer
Bill Campbell responded on 12 Sep 2017 5:59 PM

Unless I have missed this completely - the file that you need is:

MicrosoftDynamicsGP-KB975705-v10-ENU.exe

Should be SP for GP 10 back in October 2010 if that helps.

Reply