When I was importing a brand new development un-managed solution into QA environment, I faced this weird error. The import file is too large to upload.


Attempt 1:
The link added  Help me resolve this issue. was not useful in my case as it says chances of Duplicate column names which is not true in my solution. I have downloaded the log file to dig more.


When I scrolled all the way down to see the unprocessed rows. Gotcha! There was a Business rule which caused lot of trouble in Unit testing itself like not triggering at all in Quick create. So I get rid of it.

Attempt 2:
Again when I tried to import the latest solution in QA, failed this time with the same error message. Again download log & dig.... This time a new culprit!

CanvasApp import: FAILURE: One or more errors occurred.


Canvas App import failure. voila! I was trying some cool Canvas Power App into my Model driven Power App (our same CRM UCI app :)) but not so fruitful. So some messy left overs bothering me now.

1. Delete the CanvasApps folder
2. Remove this line in solution.xml

      <RootComponent type="300" schemaName="xxx_xxx_e4543" behavior="0" />

3. Clean up/Delete the below entry in [Content_Types].xml

<Override PartName="/CanvasApps/xxx_xxx_e4543_BackgroundImageUri" ContentType="application/octet-stream"/>

4. Remove this below portion from customizations.xml


<CanvasApps>

<CanvasApp>

<Name>xxx_xxx_e4543</Name>

<AppVersion>2019-03-05T18:25:29Z</AppVersion>

<Status>Ready</Status>

<CreatedByClientVersion>3.19023.12.0</CreatedByClientVersion>

<MinClientVersion>3.19023.12.0</MinClientVersion>

<Tags>
{"primaryDeviceWidth":"640","primaryDeviceHeight":"1136","sienaVersion":"49902bcf-5474-48b8-bfcd-080acff5d69b","deviceCapabilities":"","supportsPortrait":"true","supportsLandscape":"false","primaryFormFactor":"Phone","publisherVersion":"3.19023.12","minimumRequiredApiVersion":"2.2.0"}
</Tags>

<IsCdsUpgraded>0</IsCdsUpgraded>

<GalleryItemId xsi:nil="true"/>

<BackgroundColor>rgba(0, 176, 240, 1)</BackgroundColor>

<DisplayName>Bio</DisplayName>

<Description xsi:nil="true"/>

<CommitMessage xsi:nil="true"/>

<Publisher xsi:nil="true"/>

<AuthorizationReferences xsi:nil="true"/>

<ConnectionReferences>{}</ConnectionReferences>

<BypassConsent>0</BypassConsent>

<AdminControlBypassConsent>0</AdminControlBypassConsent>

<EmbeddedApp xsi:nil="true"/>

<IntroducedVersion>1.0</IntroducedVersion>

<BackgroundImageUri>/CanvasApps/xxx_xxx_e4543_BackgroundImageUri</BackgroundImageUri>

<DocumentUri>/CanvasApps/xxx_xxx_e4543_DocumentUri.msapp</DocumentUri>
</CanvasApp>
</CanvasApps>


Success!!! After all this cleanup - Solution is imported fine. Good luck.