Why my freshly imported data into CRM look gibberish?

I asked myself that question after the recent data import. You see, I'm from Bulgaria, but very, VERY rarely have to work in CRM with data on Cyrillic, until one day I had to upload a .csv list with all cities in Bulgaria, with their original names.

You understand both, my surprise and my frustration when I check the bulk import report and I found a bunch of gibberish records in my CRM.

This has nothing to do with the Display language of the user, so don't waste your time installing another language (Bulgarian in my case)

I was surprised to see that if I create a new record from CRM in Bulgarian(Cyrillic alphabets), everything looks as expected, and most importantly it is human readable.

So here is the thing. If you save your data from Excel to a .CSV file, it will be saved in ASCII/ANSI format which uses 8-bit encoding. In simple terms, encoding means mapping characters to numbers. Everything is stored as a number represented as bits in a computer so the text has to get encoded/decoded when you store/display the data. When you import the ASCII data into CRM the imported data will look like gibberish because it is being decoded as a different character set than the source data.

The trick to getting around this problem is to save the CSV file in Unicode (32-bit, Universal character set) format before you import it with CRM’s Import Data Wizard.

So you have two options to do that.

Option 1 Use Microsoft Excel

Save your file as CVG UTF-8 format.

Option 2 Use Windows Notepad app

Open the .csv file with notepad app

And then, save the file as

Change the Encoding format to UTF-8 and save the new file somewhere.

Import your new .csv file back to Dynamics CRM, and ta-da, your data will look again nice and presentable now in your desired language. This not only includes Bulgarian or any of the Cyrillic alphabet languages but also the one with special characters such as German, Danish, etc.