Prerequisites for installing Data Import Export Framework failing

Prerequisites for installing Data Import Export Framework failing

This question is answered

This is Windows 2008 R2 with SQL Server 2012. Visual Studio 2010 is also installed.

I have used process monitor to view how setup is attempting to access various registry keys and local files, and one major problem is how it attempts to access 7.0A version of the SDK. I've tried various things to try trick the installer, but I am stuck. I am sure it is the gacutil utility it needs to make sure setup can continue, but installing Windows SDK 7.1 does not do the trick.

Anyone with any bright ideas before I create a support request on this. :-(

Here is a screenshot:

Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

Verified Answer
  • I have worked together with Microsoft on this issue and there seems to bug with the installer related to Regional Settings. When I set the Regional Settings to English (United States), the installer validates correctly, but when I set it to Norwegian, Bokmål (Norway), the validation failes.

    A workaround for this is set Regional Settings to English (United States) during installation. I suspect that the gacutil is only necessary for registering assemblies at install-time and that regional settings therefore safely can be set back to original settings after the installation has finished.

    --------

    Christian Moen | Dynamics AX System Engineer, Avanade Norway

  • I have also worked together with Microsoft on this issue, and they sent me email yesterday "If OS is non-English , could you please check what is Decimal separator in Regional Settings.

    There is possible issue that if it is not “.” It cannot find gacutil. If yes, please change it and then try to install with these settings"

    Now we are happy :)

All Replies
  • I have the same problem

  • See also community.dynamics.com/.../197884.aspx

  • Well, I have made sure the gacutil is located everywhere the installer looks for it, by using Process Monitor to view any unsuccessful attempts.

    I've also installed the 8.0 SDK just to try  see if that would make the necessary assemblies discovered by the installer.

    Right now I am trying to first install this:

    www.microsoft.com/.../confirmation.aspx

    And then this:

    www.microsoft.com/.../details.aspx

    This shouldn't be this hard. ;-)

    Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

  • Hey Tommy,

    I am using a Windows 2008 R2 with SQL Server 2008.

    Before I had installed Visual Studio 2010 Premium I received very strange errors, similar to “your errors”.

    After installing Visual Studio 2010 Premium and updated it to the current version via windows update the prerequisite validation passed successfully....

    Regards

  • I will probably do the same in my sandbox, but on this exact server I do not really want to install Visual Studio 2010. We already have it on the development box which is not running SQL Server. Obviously Visual Studio 2010 Shell is installed, along with BIDS.

    I tried to install SP1 and the VS 2010 SDK, but it didn't make the installer pass.

    Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

  • So is the fix to install Visual Studio 2010 on my SQL Server 2012 server?  I'd rather not do that if it can be avoided, but I cannot get past the prerequisite checks either.

  • Hey guys,

    try to download the package again. They definitely changed something (the executable is slightly bigger now and the date of it changed to 3/17/13).

    Maybe the problem you are facing was fixed in there... But that's just a guess.

  • Thanks for the tip. The installer has changed. 

    Unfortunately for me, it still fails, even though the util is there.

    Tommy Skaue | Dynamics AX Developer from Norway | http://yetanotherdynamicsaxblog.blogspot.no/ | www.axdata.no

  • I am getting failure on SDK for Widows Tools even after downloading and installing from new installation.

    Regards,

    Akhwand Usman

  • Hi Tommy.

    Take a look at this post. The Gacutil utility needs to be in a specific directory. This worked for me.

    community.dynamics.com/.../103358.aspx

    kind regards,

    André Arnaud de Calavon

    kind regards,

    André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

    This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

  • This issue is resolved by following below steps:

    1- uninstall VS C++ redistributable (support.microsoft.com/.../de)

    2- Install Framework 4.0 with Windows SDK 7

    3- Install VS C++ redistributable again

    4- Run check list again

    Resolved!!

    Regards,

    Akhwand Usman

  • This worked for me, too -copying the gcutil files into these paths:

    C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin

    and

    C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0\Bin\NETFX4.0 Tools

    Thanks everyone for your help!

    Steve Robinson

  • I think now I´ve got it!

    On the SQL-Server you have to install Windows SDK 7.0 for DotNet 3.5

    and on AOS-Server you have to install Windows SDK 7.0 for DotNet 4.0

    This worked for me, without using a "hack" :-)

  • Yes, but if you have already installed framework 4.5 which is also a pre-req you will not be able to install Windows SDK 7.0 for .Net 3.5. In that case you will have to do steps I have posted to get going.

    Regards,

    Akhwand Usman

  • I really tried everything that I've found here and on other site on the internet, without success.