SBX - Search With Button

SBX - Forum Post Title

Error trying to log in Warehouse mobile portal. Sorry, an error occurred while processing your request. Please retry your request or contact your system administrator.

Microsoft Dynamics AX Forum

cBass asked a question on 28 Nov 2014 2:45 PM

Question Status

Suggested Answer

I followed everyting in the installation guide and enven check some troubleshooting web pages:

- I Create an AX user with the mobile warehouse role.
- Used this domain user for the application pool.

- Change the port in the web.config file for the port defined in the installation.

Still having the error. When I check in the Windows Event Log, here is the error for the Web Event:

Exception information:
Exception type: InvalidDataException
Exception message: Expected record type 'PreambleAck', found '72'.

Is there something else that need to be configured before installing the WHDP?

Thanks!

Sébastien

Reply
Nitesh Ranjan responded on 29 Nov 2014 10:45 PM
My Badges
Suggested Answer

Please review the status of AIF Inbound port related to Warehouse Portal in Dynamics AX 2012 R3

check if it is activated,

if it is in active status, then look in AIF service exception form, if you have any clue related to the issue

Please verify and update us with your findings

Reply

Hi Sébastien,

If you can't solve the answer with the links provided by Umesh, check all settings in the AX WMS setup.

Did you already configured the mobile device menus?

Can you also yell why you changed a port number in the web config file? I only had to change it during testing when I on purpose tried to install it on the same port to see what happens.

Reply
cBass responded on 1 Dec 2014 3:17 PM

Hi all,

Thank you very much for all your quick answers to my problem.

I've read them all and tried a couple of things:

- Umesh:

  • I created the default display settings
  • I created also some Workers.

- Nitesh:

  •  I installed the AIF services In AX because I didn't see it as a prerequisite for the Mobile Portal in the installation guide for Microsoft Dynamics AX 2012.
  • I checked the inbound ports and the WHSMobileDevicesServices is activated.
  • I also checked in the Exceptions Form and found nothing special.

André:

  • Had already defined a simple device menu with one work menu item.
  • From what you said I change the port back to the default 8201 in the web.config file.
    At first, I didn't see that this was for when Mobile Portal and AOS are not on the same server.

The error change in the Event Log for:

SocketException
   No connection could be made because the target machine actively refused it 127.0.0.1:8201 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.Sockets.Socket.Connect(EndPoint remoteEP) at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout) 
   http://localhost:9898/Execute/InitializeDisplay
   /Execute/InitializeDisplay
   ::1   
   False 

Is this because the application pool user is missing some Windows privileges?

Thank you again for your help!

Reply

Hi cBass,

Perhaps you can try to install a new warehouse portal on the machine. Try to use e.g. port 8999 (check if it is free) or use a port number used in my blog (Kaya consulting) provided by Umesh.

Can you then see if this works?

Perhaps it can still be related to a wrong setup of the default display settings. It fails on something called "InitializeDisplay".

Reply
cBass responded on 5 Dec 2014 2:08 PM
Suggested Answer

Hi,

Found my problem, the default port number for the Service endpoint was changed and had to reflect it in the web.config file.

I didn't have that info at that time.

Thank you!

Reply
Marek Novotný responded on 31 Mar 2015 2:07 AM
My Badges

Hi all,

I was facing same error. In my case was problem also with web.config file due to that I have AOS on other machine.


Solution is to change:

"net.tcp://localhost:port/..." to "net.tcp://AOS:port/..."

and also uncommenting <identity> and set user to same as AOS service running as it is written in web.config file.

Hope it helps.

Reply
Meet responded on 26 May 2015 6:13 AM
My Badges

Hi,

We are facing same issue. We tried all methods posted on this forum but still no luck.

1) While installing we gave 13500 as port, and updated it in web config file accordingly. 2)We also updated the username@domain field in the web config file.                                   3)We've also done the recommended settings in AX(WHM user role, creating a worker, assigning a default company). Could you please help us on this, we've been trying this from past few days.

Thanks in advance!

Reply
VDY responded on 16 Aug 2015 8:24 PM
My Badges

we also tried all the methods o this forum. but can't resolve login page issue. can someone help please. below is the error from eventviewer.

Exception type: InvalidDataException

   Exception message: Expected record type 'PreambleAck', found '72'.

Request information:

   Request URL: localhost/.../InitializeDisplay

   Request path: /Execute/InitializeDisplay

   User host address: ::1

   User:  

   Is authenticated: False

   Authentication Type:  

Reply
Iamv responded on 16 Sep 2015 12:43 AM
My Badges

could anyone solve this? i'm too facing the issue. i tried everything in this forum.

Thanks.

Reply
Meet responded on 16 Sep 2015 1:05 AM
My Badges

Hi VDY,

We were able to resolve the issue. We had configured two instances of AX on server and by default in web.config file it always takes the first instance port. We were configuring mobile portal for the second instance. Once we updated web.config file, issue resolved.

Reply
Iamv responded on 16 Sep 2015 1:24 AM
My Badges

Hi All,

I just resolved the issue.

AIF inbound port setting was for 8102  port but when i run the WSDL file, it shows port as 8202...I am not sure why. i just changed my web.config file port from 8102  to 8202 and issue got resolved. WSDL file shows net.tcp setting at the end of it.

so please have a look at that first and update your web.config accordingly whenever you face this issue. Thanks. all.

Reply
Kishan Gajjar responded on 26 Oct 2015 3:18 AM
Suggested Answer

No need to change the port please install WMDP using 8101 (default port) and keep in web.config same.

Reply
Jose David Claure Velasco responded on 26 Aug 2016 4:39 PM
Suggested Answer

Please someone could resolve this error and could help thanks

Jose David

Reply
Waris Khan responded on 6 Nov 2018 5:58 PM

Hello,

I am trying same steps you mention in your solution, but my issue still same not any changes.

Reply
Nitesh Ranjan responded on 29 Nov 2014 10:45 PM
My Badges
Suggested Answer

Please review the status of AIF Inbound port related to Warehouse Portal in Dynamics AX 2012 R3

check if it is activated,

if it is in active status, then look in AIF service exception form, if you have any clue related to the issue

Please verify and update us with your findings

Reply
cBass responded on 5 Dec 2014 2:08 PM
Suggested Answer

Hi,

Found my problem, the default port number for the Service endpoint was changed and had to reflect it in the web.config file.

I didn't have that info at that time.

Thank you!

Reply
Kishan Gajjar responded on 26 Oct 2015 3:18 AM
Suggested Answer

No need to change the port please install WMDP using 8101 (default port) and keep in web.config same.

Reply
Jose David Claure Velasco responded on 26 Aug 2016 4:39 PM
Suggested Answer

Please someone could resolve this error and could help thanks

Jose David

Reply

SBX - Two Col Forum

SBX - Migrated JS