SBX - Search With Button

SBX - Forum Post Title

AX 7: Installed Customizations not visible after manual installation of a Deployable package in Local VM for D365 Operations.

Microsoft Dynamics AX Forum

Zain Bokhari asked a question on 4 Apr 2017 2:20 AM
My Badges

Question Status

Verified

I have manually applied a deployable package on a VM following this: https://ax.help.dynamics.com/en/wiki/installing-deployable-package-in-ax7/

The package elements were successfully imported and I can see the package model and elements in classic/model view of AOT. But all elements show up in italic font and in the Build Models menu the related package model is grayed out (check-box to select for build disabled). Can anyone please guide me on what am I missing or what do I need to do next??

Reply
Suggested Answer

How would you like to build the model, if you have no source code to build it from? And why would you do it?

Installing the deployable package installed the already built model (.NET assemblies and resources). You don't have to build it, because it's already done, and you can't, because you installed only the built binaries and not the source code.

What to do next depends on what you're trying to achieve. If you just want a built model, you're already done. If you want to install source code for some reason (and not just binaries), you have to import a  model instead of installing a deployable package.

Reply
Zain Bokhari responded on 4 Apr 2017 6:18 AM
My Badges

Hi Martin,

Thanks for your response, well we have installed a deployable package and we don't need the source code for now.

Our current issue is that the elements in the package are not yet visible in Operations Menus. For instance there is a menu extension in the installed package that contains multiple items(installed with the package) added to HR menu. But none of that customization is visible.

What do we need to do so it is visible to the user?

Reply

Aha. that's a completely different questions that what you asked originally.

There may be several reasons. For example, maybe the package was successfully deployed but nobody was given permissions to see new menu items.

By the way, which kind of environment are we talking about?

Reply
Zain Bokhari responded on 4 Apr 2017 8:24 AM
My Badges

We have installed D365 Operation demo machine in a local VM and then installed a deployable package in it for a test run.

Even if the permissions have not been assigned to users the Administrator should be able to see the added menu items right?

Plus the installed items appear in italic font in AOT for some reason. 

Reply
Verified Answer

That was just an example. Maybe you don't have a license. Maybe you forgot to enable a configuration key. Or something.

You see it in italic because you don't have source code, as I explained in my first reply (and before we made clear that you're actually solving a different problem).

Reply
Zain Bokhari responded on 4 Apr 2017 9:32 AM
My Badges

I have updated the thread Statement to the current issue. Thanks for the suggestions and clarification. I will try a few things and come back if needed.

Reply
Zain Bokhari responded on 5 Apr 2017 7:46 AM
My Badges
Verified Answer

Hi Martin,

We missed the license file while importing the package. Importing it resolved the issue.

Thanks for the help.

Reply
Anton Bozhok responded on 14 Sep 2017 1:13 PM

Hello Bokhari, I have a similar problem, after installing the package on the demo environment through LCS, the interface does not display the menu items that should be after installation. Please tell me where to look

Reply
Manoj V responded on 14 May 2018 6:18 PM

I have similar issue in My Local Dev machine . we are using PU12 . The model is still in italic and greyed out .What license file should we import . Its my local machine , so is it a D365 developer license file? . Please assist

Reply
Manoj V responded on 14 May 2018 6:22 PM

Martin , how to get the source code . The model in imported as a deployable package has only asembles , JSOn files and DLL's . So is that why it is greyaed out and italic  .

Reply

If you want source code, ask the owner for source code instead of just compiled binaries (deployable package).

Reply
Verified Answer

That was just an example. Maybe you don't have a license. Maybe you forgot to enable a configuration key. Or something.

You see it in italic because you don't have source code, as I explained in my first reply (and before we made clear that you're actually solving a different problem).

Reply
Zain Bokhari responded on 5 Apr 2017 7:46 AM
My Badges
Verified Answer

Hi Martin,

We missed the license file while importing the package. Importing it resolved the issue.

Thanks for the help.

Reply
Suggested Answer

How would you like to build the model, if you have no source code to build it from? And why would you do it?

Installing the deployable package installed the already built model (.NET assemblies and resources). You don't have to build it, because it's already done, and you can't, because you installed only the built binaries and not the source code.

What to do next depends on what you're trying to achieve. If you just want a built model, you're already done. If you want to install source code for some reason (and not just binaries), you have to import a  model instead of installing a deployable package.

Reply

SBX - Two Col Forum

SBX - Migrated JS