How to disable the "Do you want to view only the webpages content that was delivered securely? popup for custom pages added to CRM

How to disable the "Do you want to view only the webpages content that was delivered securely? popup for custom pages added to CRM

  • Comments 9

We had a custom page developed for a customer using CRM Live install. In this case we had the customer host the custom pages locally within their intranet on a IIS server. The URL of this website was added in the IFRAME on the CRM Form.

We noticed that as soon as we added the IFRAME, the customer would receive the following alert "Do you want to view only the webpages content that was delivered securely?".

This was because of the change in the security level of the pages. While CRM Live is hosted on a secure "HTTPS" protocol to provide more secure access to CRM, our custom pages uses "HTTP" protocol, so every time when CRM is accessed you get this prompt.

To remove this follow the below steps.

Go to Tools --> Internet Options --> Security Tab. Here select the proper zone under which your custom pages or the "HTTP" pages came.


Now select "Custom Level" button.

Here go to Miscellaneous --> display mixed content and select "Enable" option as shown in the below screen shot.


With this done, you will not be prompted anymore.

  • Some time over the last month IE did an auto upgrade to my PC and I kept getting this pop up "Do you want to view only the webpages content that was delivered securely" in my webmail.  Talk about a pain in the rear,  Butt thanks for the tip.  Used it here on your site and my webmail as been fixed.  Thanks again.

  • wow thank bro..u solved my problem

  • Thanks so much.. fixed right away !!

  • Wow, thanks!!! It was soooo annoying!

  • Thanks....just got windows 7 computer...this kept popping up....problem solved! tytytytytytytyty!

  • Outstanding. That was an annoying warning. Very good and easy fix, thank you

  • Thanks very much!!! The aweful anoying message has vanished!!! You ROCK!!!

  • I had a silimar problem, not exactly the same though... It was due to the get started paned which had a wrong url configured. I explained everything in my blog : laurentbel.com/.../dynamics-crm-2011-error-only-secure-content-is-displayed

    Hope this will help someone.

    Laurent.

  • This can also be done via GPO:

    Windows Components/Internet Explorer/Internet Control Panel/Security Page/Internet Zone

    Windows Components/Internet Explorer/Internet Control Panel/Security Page/Intranet Zone

    Windows Components/Internet Explorer/Internet Control Panel/Security Page/Trusted Sites

    Look for "Display mixed content" under each, enable it and then change the setting to enable inside of it as well. Good find.