You set regarding in the Dynamics 365 App for Outlook, but you don’t get the results you expect.

If you are in Outlook desktop, you should be aware that behind the scenes webpages rendered in Outlook (and the entire Office platform) are rendered in Internet Explorer. This issue can be caused by cache issues in IE.

Microsoft is working on a fix for the issue, but for now, if you or another user has this problem, the following steps should fix the issue (as reported by Lu Hao on this Dynamics Community forum thread).

Clear your browser cache

  • Shut down IE and Outlook. Make sure in task manager that no IE or Outlook processes are running.
  • Clear Internet Explorer Cache, Cookies, History, Temporary Internet files completely. 
  • There is a setting in Internet options under Browser history section: Settings > Caches and databases tab. If has a cache, delete it. 
  • Restart Outlook.

F12 Chooser

If this bug only appears in desktop client and clearing the cache via Internet Options does not help, try clearing it via F12 chooser. Here is the process (steps are not applicable for Windows 7)

  • Open Dynamics app in desktop client
  • Open IEChooser.exe in %WindowsFolder%\System32\F12
  • Click on Dynamics 365 thread
  • Go to Network tab and click clear cache button

Cover photo by Annie Theby