And there are some interesting consequences. For example, I was wondering what would happen to a Flow if I deleted a field used in that flow.

Here is the flow:

image

And here is the field which I’m just about to delete from Dynamics:

image

First of all, it does not have any dependencies, at least not according to what Dynamics is telling me:

image

So, I was able to delete it without any problems:

image

Now the flow did not recognize it yet even though I did refresh the browser:

image

How come? A few minutes later, here is what I see – there is definitely a change:

image

But the flow keeps working:

image

Not sure if flow behavior depends on the connector in this situation – maybe some connectors will fail to execute an action if there are missing attributes.. Although, I guess it might also be the expected behavior – if the attribute is “empty” in Dynamics, it would be missing from the output of the previous step (think plugins, late binding.. if there is no value, the attribute just won’t be there in the attributes collection). Which, from the outlook connector standpoint, is probably no different from when the attribute is missing for any other reason (as in when the attribute has been removed).

Still, if, logically, the Flow did expect that attribute to be there, you may get some unexpected results which you will only recognize later. What are we going to do with that? I am not sure at this point, but, I guess, the whole Power Platform is still in the process of bringing everything together, so there could be this kind of edge cases which will be handled later.