Suddenly on Thursday the 14/11/2019 NZST a customer was having issues with Dynamics 365 when using Chrome, it was freezing and displaying a blank/white tab. Users would need to restart Chrome to load Dynamics 365 again.

I was unable to replicate this issue on my laptop, however the users affected were using a Citrix client. This problem seems to be more prevalent with users on a server, where multiple users will be active at once.

A user from the Google support thread (https://support.google.com/chrome/thread/19713332?hl=en) found that the “occlusion” setting in Chrome was causing this to happen. Note, this is a Chrome issue that can affect any web page. This has been nicknamed the "White Screen of Death" (WSOD) error.

Here is Google’s response to this problem:

“Our mission is for Chrome Browser to be fast and efficient. We’ve been working on an optimization for when Chrome is hidden behind another window, to avoid having to draw content that a user will never see.

This optimization was tested in the Beta channel of Chrome for the past 5 months, and was activated for all users of Chrome 78, on Nov 12.

After the roll out, we received reports that in some virtual environments, Chrome on Windows displays a blank page, which may be because Chrome mistakenly believes it's covered by another window. As soon as we confirmed the reports, the feature was disabled.

If Chrome on Windows is displaying blank pages, restart Chrome. On the next start, this feature will be disabled.

We also want to provide an explanation of how this change was rolled out. For some features, Chrome uses a gradual roll out process that happens more slowly than the main roll out. This allows us to quickly revert a change if we discover a bug that wasn't uncovered in prior testing.

Once we received reports of the problem, we were able to revert it immediately. We sincerely apologize for the disruption this cause”

While Google state the optimization was activated for Chrome 78, other users on previous versions also have report the same problem.

There are two settings for “occlusion”.

  1. “Calculate window occlusion on Windows”: “throttle and potentially unload foreground tabs in occluded windows”. This causing the chrome tabs to hang/freeze and go white. Google has admitted window or tab can be incorrectly detected as covered by a window (occlusion), causing this to happen.
  2. “Enable occlusion of web contents”: web contents will behave as hidden when it is occluded by other windows.

Google has now disabled the Optimisation, however if this still a problem the Workaround is:

For large networks you can try running the command line: --disable-backgrounding-occluded-windows

You add this command to your target for the shortcut.

image

Otherwise you will need to manually change the chrome setting:

image

1. Type “chrome://flags” into the URL bar

2. Search for “occlusion”

3. Set “Calculate window occlusion on Windows” to “Disabled”

4. Set “Enable occlusion of web contents” to “Disabled”

5. Restart the browser