Morning all,

Here's an interesting problem to test the very best.

I have a user whose email synchronisation stopped at some point in the last month.

We have CRM 2013, server-side sync to Exchange 2010 (I know, we live in the past. What can you do). This organisation was created last September and has worked fine. Other users work fine.

The symptoms I'm seeing are as follows

  • Emails sent from within CRM are sent and replies tracked normally
  • Emails sent/received into Outlook are not tracked (you can set regarding, but the email is never tracked and never appears in CRM)
  • Whenever this user's synchronisation cycle runs, the same selection of (about 30) emails has its modified date updated to the current date and time. I can find nothing that these emails have in common. Their dates span the time this organisation has existed. Some are owned by this user, some are owned by other users.
  • I have warnings of 'MimeConversionError' generated in the user's mailbox, but I don't know to what these errors refer. They also don't disable the mailbox.

Have tried disabling the mailbox and testing and enabling it again, restarting the async service, deleting the org from the Outlook plugin and setting it again. Client or server tracing gives me no information.

Other information

The mailbox table records the LastMessageID, this seems to be the most recent email in the user's outlook, so CRM seems to be talking to Exchange and pulling some information back.

There is a large number in the TransientFailureCount field on the Mailbox table, but I'm damned if I can find out what this translates to other than it's bad.

It feels like something is cached somewhere that these particular emails need updating, so it updates them but that cache (if such a thing exists) is not removed.

Any comments, theories, insults welcomed from things that may seem obvious to things that seem crazy. I've spent a week banging my head against this so I'm prepared to try anything

Thanks

Neil