Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics CRM forum
Answered

Sharing a record results in all child record being seen by the shared with Party

Posted on by 110

Hello it's been a while since I configured this security configuration:

I configured security for a specific set of users that can only view their own contacts and their own opportunities. 

However when we share a contact with them, they can view all opportunities for that contact record even though their security only allows them, create, share or append to, append only their own opportunities?

Thanks

  • Rakesh90 Profile Picture
    Rakesh90 200 on at
    RE: Sharing a record results in all child record being seen by the shared with Party

    Yes. I would suggest creating a team like 'Opportunity reviewers'. Assign the security role that already has Read permissions on Opportunity to this team. You can then add/remove users to this team who need Read access to Opportunity as and when required.

  • Bill Hanna Profile Picture
    Bill Hanna 110 on at
    RE: Sharing a record results in all child record being seen by the shared with Party

    Thank you for that, but now I have other users that need to see that, do I have to change their security to view all opportunities?

  • Verified answer
    Rakesh90 Profile Picture
    Rakesh90 200 on at
    RE: Sharing a record results in all child record being seen by the shared with Party

    Hi,

    This is because the Contact - Opportunity relationship has a Parental type relationship out of the box.

    pastedimage1630491141786v1.png

    You can update this by changing the Type of behavior to 'Configurable cascading' and Share to 'Cascade user-owned'

    pastedimage1630491218087v2.png

    If the above suggestion worked, please mark my answer as verified

  • Suggested answer
    Ram Prakash Profile Picture
    Ram Prakash 2,285 on at
    RE: Sharing a record results in all child record being seen by the shared with Party

    Hi @Bill Hanna,

    Try checking the Relationship behaviour.

    Open CRM System 

    Click Settings

    Then Select Advance Settings

    Then Select Customisation and customize the System

    Expand Entities, Expand Opportunity

    Click Relationship then open contact relationship and check the Share Behaviour ( change it to None)

    Try the same for account too.

    Please marke as Answer if it's helpful

    microsoftcrmtechie.blogspot.con

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,995 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,610 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans