Skip to main content

Notifications

Announcements

No record found.

Dynamics 365 Community / Forums / Finance forum / Custom Module not gett...
Finance forum
Answered

Custom Module not getting displayed

Posted on by 4
Hi,
I had created a custom module in X++. Then created a extension of MainMenu menu in my project and added my model in a new reference (changed the properties of this new Menu reference too). Still upon build, my custom module is not visible.
 
I saw that in some other community post, someone else faced a similar problem and it was caused because a menu item was selected as a startup object and he pressed F5. However I have just done a normal build. Can anyone please help me out?
  • Waed Ayyad Profile Picture
    Waed Ayyad 2,983 on at
    Custom Module not getting displayed
    Hi,

    Is your issue resolved? If yes, mark the answers that helped you as verified.


    Thanks
    Waed Ayyad
     
  • Verified answer
    André Arnaud de Calavon Profile Picture
    André Arnaud de Cal... 283,632 Super User on at
    Custom Module not getting displayed
    Hi,
     
    You can go to Visual Studio > Extensions > Dynamics 365 > Build models.
    Then select your model(s) to be built. On the tab Options, also select the option to synchronize the database. Sometimes, this helps instead of a build via a project or solution.
     
    PS. On the next page, you can find a Finance and Supply Chain Management forum where you can post Dynamics 365 F&O-related questions. Find Answers | Microsoft Dynamics 365 Community  
  • CU30040927-0 Profile Picture
    CU30040927-0 4 on at
    Custom Module not getting displayed
    Hi Mohammed,
     
    Thank you for responding. Actually I forgot to ad in my question that I was working on D365 F&O and not on MS AX 2012.
    Still I think that D365 does not allow you to add a menu directly to the MainMenu extension.
     
    Instead the only option I could find is to add a new menu reference and attach my custom menu there
  • CU30040927-0 Profile Picture
    CU30040927-0 4 on at
    Custom Module not getting displayed
    Hi Andre,
    I am working on MSD 365 F&O. Actually I could not find a community for Dynamics 365 F&O, as such posted it in this community.
    No, I do not have any configuration key set for my custom menu or menu item. 
    I have build only the project I was working on, instead of doing a full build on the solution.
  • Suggested answer
    André Arnaud de Calavon Profile Picture
    André Arnaud de Cal... 283,632 Super User on at
    Custom Module not getting displayed
    Hi,
     
    Are you using Dynamics AX or Dynamics 365 F&O? You posted the question in the Dynamics AX forum, but you are talking about an extension. 
     
    Do you have a configuration key on your menu or menu items? In case you are using Dynamics 365, have you built the whole model or only the project or solution? Have you also tried running a database sync?  
  • Suggested answer
    Mohamed Amine Mahmoudi Profile Picture
    Mohamed Amine Mahmoudi 4,826 User Group Leader on at
    Custom Module not getting displayed
    Hi,
     
    you must
    1. drag your newly created menu to the MainMenu.
    2. build the object
    3. close and reopen AX
     
    Best Regards,
    Mohamed Amine MAHMOUDI

Helpful resources

Quick Links

Can you answer this forum question?

You could make someone's day!

Community Newsletter - May 2024

Kudos to our community stars!

Community Spotlight of the Month

Kudos to Mohamed Amine Mahmoudi!

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,632 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 224,528 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,146

Featured topics

Product updates

Dynamics 365 release plans