Skip to main content

Notifications

Announcements

No record found.

Customer Insights - Journeys forum
Unanswered

Segment Members Suddenly not Visible in just one Segment!

Posted on by 8

Hi there!

I have created a bunch of segments for the marketing team which all seem to be working fine. When I created them I could see all the members listed.


Just one segment has stopped showing me the members and I'm struggling to troubleshoot it. 


The segment has some logic of it's own and then references two other segments - one is added as an 'OR' case, the other 'BUT NOT' for a suppression list.


The other two segments both show me their members - no problem.


There are 121 members in the problematic segment, but we can't see the list although the segment itself appears to be working looking at the relevant customer journey.


Any bright ideas? It definitely isn't the 'Segment View not active' issue as other segments are all working as expected!

pastedimage1675339829720v1.png

Categories:
  • PhiltheJuggler Profile Picture
    PhiltheJuggler 8 on at
    RE: Segment Members Suddenly not Visible in just one Segment!

    Weirdly - if I split the top part off into a segment of it's own and then make a new segment which simply combines the three elements it seems to work!

    This segment also listed members before I added the suppression segment at the end.

    It's almost like there is a maximum number of terms that a segment can cope with on one page.

    pastedimage1675557451078v1.png

  • Leah Ju Profile Picture
    Leah Ju Microsoft Employee on at
    RE: Segment Members Suddenly not Visible in just one Segment!

    Hi PhiltheJuggler,

    Could you share details about the structure of the segment if you can?

  • PhiltheJuggler Profile Picture
    PhiltheJuggler 8 on at
    RE: Segment Members Suddenly not Visible in just one Segment!

    Thanks for the suggestions - firstly I have admin rights across Dynamics and Marketing so I should be ok on permissions. I could see all the members when I first built the segment but now I can't. Neither can other members of staff - but it is only this segment that has the problem.

    The structure of the segment is one block of logic and two additional segments - I rebuilt the logic block as a separate segment and made a new segment of the three segments combined and this shows the members although weirdly has 122 members instead of 121 - the logic is the same!

    I noticed when first building the segment (which had a lot of parameters included) it initially refused to estimate the size of the segment and just didn't work properly - I split the segment into two separate segments and that appeared to work initially.

    I tried rebuilding the whole segment and that didn't work either - I'm just really puzzled!

  • Leah Ju Profile Picture
    Leah Ju Microsoft Employee on at
    RE: Segment Members Suddenly not Visible in just one Segment!

    Hi PhiltheJuggler.

    It's so strange.

    Only you can't see members of the segment? or all users?

    Do you have sufficient privileges on contact entities?(The segment member list only shows those contacts that you are permitted to view. It may also include additional contacts for which you don't have read permission.)

    You can try to create one new segment with same logic and check if you can see the members.

    Or you can try to clear browser cache to test again.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,696 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,490 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans