Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics CRM forum
Suggested answer

Help! Embedded PowerBI report in Dynamics dashboard not authenticating

Posted on by 75

I am using the relatively new feature of embedding PowerBI reports into a Dynamics365 CE system dashboard. 

All my users have PowerBI Pro licences.

The report in PBI has been shared with the users.

The report is embedded into a dashboard in a model driven app using the new Add Dashboard -> Power BI Embedded.

Using Edge logged in as my user account, when I navigate to the dashboard in Dynamics, I get the grey PBI icon and the sign in button. Clicking this moves me to a new tab where I choose my sign in account. This then takes me back to the dashboard where the spinning icon spins for 5-6 seconds. I then get the same icon and the text 'Authentication wasn’t successful. You need to sign in to your Power BI account to view or edit Power BI tiles' and the Sign in button again. 

This just continually loops and never logs into the PowerBI report. 

If I click the Open in PowerBI button, I can log into PowerBI and view the report without any problems.

 

If I open a new Edge window in Guest mode, log into the same account, the dashboard opens without any prompt perfectly fine. 

Anyone have any ideas how to fix this? Making our users log into a new Edge window as a guest is not a solution.

  • Suggested answer
    RE: Help! Embedded PowerBI report in Dynamics dashboard not authenticating

    Hi, I hope you are doing good.

    When accessing to an embedded Power BI report in Dynamics, make sure you added the user as workspace member in Power BI Service that is because sharing the app is not enough.

    If this answers your question, please check it as verified to help others finding useful information.

    Welcome this amazing community.

  • Suggested answer
    meelamri Profile Picture
    meelamri 13,198 User Group Leader on at
    RE: Help! Embedded PowerBI report in Dynamics dashboard not authenticating

    Hi, 

    As it works without any problem using a new session (Guest mode) on Edge. I recommend that you clear your browser's cache. 

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,986 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,588 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans