Skip to main content
Microsoft Dynamics CRM forum
Suggested answer

Organizations upgrade to version 9.0.13.11 failed

editSubscribe (0) ShareShare
ReportReport
Posted on by 135

I have just recently upgraded my Dynamics 365 on-premise server software version 9.0.6.9 to the latest Microsoft Path Feb 2020 release version 9.0.13.11. The installation was completed with no issues. However, I am getting errors when I am upgrading my organizations. 

 16:38:50| Error| Import Organization (Name=xxxxx, Id=xxxx) failed with Exception:
Microsoft.Crm.CrmException: Failed to install organization db updates. One or more actions have failed. Failing actions are: InstallCrmSystemConvertedSolutionsAction
at Microsoft.Crm.Tools.Admin.OrganizationDBUpdateInstaller.ProcessFailedActions()
at Microsoft.Crm.Tools.Admin.OrganizationDBUpdateInstaller.Execute()
at Microsoft.Crm.Tools.Admin.ImportOrganizationInstaller.Import(Guid organizationId, String organizationUniqueName, String organizationFriendlyName, String sqlServerName, String databaseName, Uri reportServerUrl, ICollection`1 users, MultipleTenancy multipleTenancy, Boolean patchOnImport, OrgDbUpdateMode orgDbUpdateMode)

Did anybody else come across this issue?

Any help is appreciated, thanks 

 

Categories:
  • PhilipK Profile Picture
    PhilipK 582 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    See if you first can update to 9.0.9.4, if successful take a backup and then move further to 9.0.10.10.
    The 9.0.10.10 update comes with a SalesPatch(solution) which have caused many failing upgrade attempts as can be seen if searching the forum.
    You should see a SalesPatch error if this is the case.

    If so the best way, at least for us was to comment out that line from the 9.0.10.10 Update bits, upgrade the affected organization(s) without the SalesPatch and the try Importing it manually via "Import Solution" from the web client.
    As it will fail you will now get a more clear view of what's in your Org that causes the issue as you can download the Import log and see  every object it tries to update.

    In our case we had issue with some altered "ootb" security roles which then fixed(long story) and were able to import the SalesPatch.
    Other than that, a common script that we at least had to run prior to upgrade(thus from v8.2->9.x) was.

    UPDATE Entity
    SET IsOfflineInMobileClient = 1
    WHERE ObjectTypeCode IN (953, 954) AND IsOfflineInMobileClient = 0


    Not sure if the SQL script above is needed in your case thou as you are already on v9 but you could check if returns any by just rewrite it to a select statement.

    Best regards. /Philip

  • Vijitha V Profile Picture
    Vijitha V 75 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    The below link helped me find the exact error.

    community.dynamics.com/.../dynamics-365-upgrade-failed

  • Vijitha V Profile Picture
    Vijitha V 75 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    Facing the same error while importing organization. Was anyone able to fix this error?

    Please update!

  • Bill Liu Profile Picture
    Bill Liu 30 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    Hi Bro, we also encounter this issue, did u find the solution now? thanks for you help.

  • Suggested answer
    James Horsley Profile Picture
    James Horsley 140 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    Strongly recommend applying Update 0.18 - at least up to 0.14 I had all sorts of different upgrade org issues - fix one then hit the next ... moved from 0.14 to 0.18 and that sorted most (never tried 0.15,0.16 or 0.17)

  • odinb Profile Picture
    odinb 10 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    We made a test using only CRM 365 (On-Premise) fresh installation and a new Organization generated during the installation, when we tried to upgrade the db to 0.14 we got the same error and found this on the Event Viewer

    CrmTrace encountered an error. Additional Info:ab96c7f1-4033-43b2-93c4-2b645a4bf58a (Reporting Process:Failed to send lifecycle change notification, AppDomain:System.TypeInitializationException: The type initializer for 'Microsoft.Crm.BusinessEntities.DataSyncNotificationHelper' threw an exception. ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.ServiceBus, Version=2.7.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Does anyone knows how I could add this dll to a new server?

  • Abdullah Çelik Profile Picture
    Abdullah Çelik 90 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    im also having the same issue. applying UpdateParentSolutionIdForSolutionPatches.sql does not fix the issue.

  • odinb Profile Picture
    odinb 10 on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    I tried this but it failed again.

    Thanks in advance

  • Ayaka Iwai Profile Picture
    Ayaka Iwai on at
    RE: Organizations upgrade to version 9.0.13.11 failed

    According the error log you provided, it seems this is a known error and I found a script to fix this issue.

    Please run the script that is located in the following directory on the server:

    C:\Program Files\Dynamics 365\Setup\Serviceability\Latest\Actions_Org\Install\UpdateParentSolutionIdForSolutionPatches.sql

    After running this script, please try upgrade again.

    Please don not forget to make a backup of the Data base before running the script.

    I recommend you to create a support ticket for further investigation if the issue is not resolved.

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,045 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,570 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans