Skip to main content
Microsoft Dynamics GP forum
Suggested answer

Unable to open PDF attachments

editSubscribe (0) ShareShare
ReportReport
Posted on by
Hi all,
 
We have a user who is experiencing issues opening PDF attachments via GP 2018, this is occurring for all PDF attachments, although opening PDFs outside of GP work fine.
 
GP is accessed via a Terminal Server, along with around 40 other people, and no one is experiencing this issue except for this one user.
 
Here is the error message that is appearing:
 
-----
 
Unhandled object exception:

The source was not found, but some or all event logs could not be searched.  To create the source, you need permission to read all event logs to make sure that the new source name is unique.  Inaccessible logs: Security.
 
EXCEPTION_CLASS_OBJECT_EXCEPTION
ExceptionSubClass:-2146233078
 
-----
 
The error is generally unhelpful, and seems to be pointing to the fact that it can't open where the error is located, rather than actually showing the PDF error itself.
 
We created a test user and logged into it via this user's windows profile, and the same thing happened. However, when we tried logging into the test account on another user's session, it worked without any issues.
 
Has anyone run into anything similar before or have any suggestions on what might resolve this?
Categories:
  • Suggested answer
    Judy Profile Picture
    Judy on at
    Unable to open PDF attachments
    Hi, please refer to the MS document to configure event log security locally:
    Hope it helps.
     
    Best Regards,
    Judy

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Georg Glantschnig…

Industry experts answer burning questions directly from our amazing Community…

Setting Up Knowledge Sources for Copilot…

Look at how configuring a comprehensive knowledge base is crucial…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,045 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,570 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans