Skip to main content
Microsoft Dynamics GP forum
Suggested answer

Email Button Greyed Out

editSubscribe (1) ShareShare
ReportReport
Posted on by 30

Dynamics 2016 on-prem
Outlook 365 (but I set it up as an Exchange profile...maybe that's my issue?)

I read Leslie Vail's blog post "Setting up E-mail in Dynamics GP" (great article!), but am still stuck with the email button being greyed out. I've supported GP since version 9 for a couple different companies, and believe it or not, no one has wanted to use the email functionality...until now. I've gone through all of the setup, but the email button in the toolbar is greyed out.

I also read the forum post "Emailing Statements grayed out" here in the community, but it wasn't quite there either.

Can you point me in the right direction?

Categories:
  • Caye Solutions Profile Picture
    Caye Solutions 30 on at
    RE: Email Button Greyed Out

    Justin,

    Thank you for the thorough reply. I will step through this and see where it gets me.

    I am currently working on Sales Transaction Entry but will be (hopefully) enabling the email functionality in the other areas as well.

    Thanks again, I'll check back here and let you know my results.

    -Jody

  • Suggested answer
    RE: Email Button Greyed Out

    Hello Caye,

    The biggest question is what exactly are you trying to email?

    There are many different setups depending on the module, with the most common ones being covered in the Email Troubleshooting Guide here:

    community.dynamics.com/.../dynamics-gp-email-troubleshooting-guide-1743830067

    The two common ones would be Remittances and Sales Orders. For sales documents its important to note that we can only email the "Blank Paper" versions of the reports.

    For Remittances I will just copy out what I have in the guide:

    Send Documents in email check box is grayed out when trying to send a Remittance

    Note: Common issues for PM EFT Remittances

    Issue:  User is attempting to email Remittances, but the checkbox is grayed out:

    Cause: This issue has a few different causes, usually setup or 3rd party involvement

    Solution: Try the following:

    1. Check to see if the vendor is setup to allow for emailing:

    a. Go to Purchasing >> Cards >> Vendor >> select a vendor >> E-mail.

    b. In the Send Forms as Email section confirm that Vendor Remittance check box is checked.

    3. If this is correct, check to see if Mekorma MICR is installed, if so make sure the Mekorma MICR System Options are set to have email enabled, or else the "Send Document in email' checkbox in the Remittance window will not be available to mark (or grayed out).  To check this setting, go to Microsoft Dynamics GP | Tools | Setup | System | Mekorma MICR | System Options.  Mark the checkbox for 'Enable Email Remittance' and click Save.

    4. More information regarding issues with this process can be found here:

    community.dynamics.com/.../quick-step-guide-to-e-mail-pm-eft-remittances-in-mdgp-2015-2016

    Outside of these the rest of the time it comes down to odd setup issues like customers not setup with a Statement ID or not setup for emails.

    Hopefully this gives you enough to go off of.

    Thanks!

Helpful resources

Quick Links

What Motivates a Super User?

We know many of you visit the Dynamics 365 Community and Power Platform…

Demystifying Copilot with Sundar…

Industry experts answer burning questions directly from our amazing Community…

Enabling Copilot Case and Conversation…

Agents can easily recap an ongoing chat, transcribe a voice conversation…

Leaderboard

#1
Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 282,978 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 222,562 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,138

Product updates

Dynamics 365 release plans