Skip to main content


Dynamics 365 general forum

Outlook Plugin unable to authenticate after SSL upgrade

Posted on by 2

I've searched a lot of answers online but haven't been able to find anything.

We recently updated the SSL wildcard cert of an on-prem Dynamics CRM. Everything is working now after the upgrade, EXCEPT the Outlook Plugin can longer authenticate. I'm not sure what might have changed.

Previously when initially setting up the CRM Plugin it would prompt for sign in with a blue-color sign in box, it looked similar to the default Dynamic Web GUI log in.

However, now it pops up with a Black-titled box, and no matter which credentials are entered it gives an error that 'authentication failed.'

I'm not sure what setting needs to be changed to get the previous pop-up box to appear, the one that actually worked.

Could anyone point me in the right direction about this issue? Thanks!


  • jdalske Profile Picture
    jdalske 536 on at
    Outlook Plugin unable to authenticate after SSL upgrade
    We are experiencing the same issue.  365 on-premise.  After updating, the app fails at the AuthenticationProvider step.  We tried to re-enable the mailboxes and that didn't work.  Did you ever figure this out?
  • LuHao Profile Picture
    LuHao 40,840 on at

Helpful resources

Quick Links

Upcoming TechTalk: Copilot Capabilities…

Review the Copilot features that are currently available in Dynamics 365 Finance…

Demystifying Copilot: Service Edition with Sundar Raghavan

Sundar answers more questions about Copilot for Service...

Dynamics 365 Business Central vs Finance and SCM

Take a look at the key differences between Business Central and…


Andre Arnaud de Calavon Profile Picture

Andre Arnaud de Cal... 283,414 Super User

Martin Dráb Profile Picture

Martin Dráb 223,394 Super User

nmaenpaa Profile Picture

nmaenpaa 101,140

Featured topics

Product updates

Dynamics 365 release plans