Skip to main content

Notifications

Announcements

No record found.

Customer Service forum
Suggested answer

Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

Posted on by 50

Hi

Today I see that has been removed in my Dynamics 365 instance all embedded video in the Knowledge Articles

I've controlled the allow list and seems correct:

pastedimage1683727808616v1.png

Now, If I try to add an emdebbed video (iframe) using the toolbar (or also directly in html), 

pastedimage1683737112396v2.png

I see the video and I can save it  

pastedimage1683737167077v3.png

After refresh (F5) in the browser I see the video is removed!

pastedimage1683737284493v4.png

Any idea?

Regards

Vincenzo

Categories:
  • Sayen Zhang Profile Picture
    Sayen Zhang on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Hi Vincenzo,

    I am glad that you find the key issue!

    From the screenshot DB limit IO db resource limit max is 600k, workload minimal routed to secodary is timing out. It looks that the environment has a bad performance.

    Here is a reference link: Service protection API limits (Microsoft Dataverse) - Power Apps | Microsoft Learn

    Best Regards,

    Sayen Zhang

  • Vincenzo Profile Picture
    Vincenzo 50 on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Thanks Sayen,

    I've just seen that if I remain on the Knowledge article page for more than hour the video appear  (it return also in HTML section!)

    Probably there are some actions that Dynamics do that going in error, I see in console.....It's strange that take this time:

    pastedimage1683900666773v1.png

    Best Regards

    Vincenzo

  • Bassey Profile Picture
    Bassey 9 on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Hi Vincenzo

    I worked on something similar a while ago, please give me some time to check for the solution.

    Else you can raise a ticket to Microsoft.

  • Suggested answer
    Sayen Zhang Profile Picture
    Sayen Zhang on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Hi Vincenzo,

    Thanks for your information.

    It seems that whatever we embed video in exist Knowledge Article or new Knowledge Article, it will disappear seconds ago.

    Can you check if any flows are triggered in production environment when you embed video?

    If you have difficult to check, I suggest you create a support ticket for professional assistance following the below procedure. 

    Get Help + Support - Dynamics | Microsoft Docs 

    Best Regards, 

    Sayen Zhang

  • Vincenzo Profile Picture
    Vincenzo 50 on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Hi Sayen

    I've done the two tests:

    1. Created a new KB article "Test Video Removal", embedded the video using icon in toolbar, Saved it, waited 10 seconds, refreshed the page and video disappear in Designer and in HTML sections

    2. Edited the KB article "Test Video Removal" just created, inserted the <iframe>......</iframe> taked from vimeo Share icon, saved it, waited 10 seconds, refreshed the page and video disappear in Designer and in HTML sections

    It's very strange!!

    I would also like to give you another element: this only happens in production and not in other test environments

    Regards

    Vincenzo

  • Sayen Zhang Profile Picture
    Sayen Zhang on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Hi Vincenzo,

    Thanks for your confirmation.

    Could you please do the following two tests?

    1. Create a new Knowledge Article and embed the video, wait 10 seconds, refresh the page to see if the video exists.

    2. Edit the html in the Knowledge Article which the video disappeared and save, refresh the page to see if edit exists.

    Best Regards,

    Sayen Zhang

  • Vincenzo Profile Picture
    Vincenzo 50 on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Hi Sayen,

    Thanks for your answer,

    Sure, I save it, wait 10 seconds, refresh the page and the video (youtube or vimeo) disappear.

    I've had this problem when the allow list did not contain the right URL, but now has been added.

    The other strange thing is that the videos was visible on the articles, starting from yesterday any KB article do not contain more the html part of video

    Regards

    Vincenzo

  • Sayen Zhang Profile Picture
    Sayen Zhang on at
    RE: Unable to embed video in Dynamics Knowlede Article even if the url is in allow list

    Hi Vincenzo,

    Hope you are well.

    I know it's silly to ask, but I'd like to ask you to confirm if you update the knowledge article after embedding the video.

    Best Regards,

    Sayen Zhang

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,995 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,610 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans