Skip to main content

Notifications

Announcements

No record found.

Finance forum
Unanswered

Failed deplyment

Posted on by 170
Hi,

When i release code from DevOps to tier 1 environment, i get these warnings/errors
 


 
  • CU04051814-0 Profile Picture
    CU04051814-0 170 on at
    Failed deplyment
    Hi Martin,

    The environment is working properly, so i think i should face an error before running the SSL certificate. Or do you think i should try it anyways?

    Hi Anthony,

    Yes i tried to deploy the same package. I'm thinking to just create a new environment

    For your check list:
     
    Check admin account is still default in LCS  what do u mean? how can i check that?
     
    Check diskspace   already DONE
    Check everything closed, e.g. visual studio already DONE
    Restart box and retry   already DONE
     
    Make sure custom code on the box is in a build state - if not, build models and then restart (no sync needed)  how can i build my models without connecting to my visual studio? because even though this is a cloud hosted environment, but it's used for testing so currently no mapping is done in VS, do you mean i shall do the mapping then build?
     
    Rotate secrets (maintain -> Rotate Secrets)  same question I told Martin, why would I do this step if I'm not getting any errors?
     
    Finally the sledgehammer approach - provision a replacement  it seems that's the only option
  • Martin Dráb Profile Picture
    Martin Dráb 224,910 Super User on at
    Failed deplyment
    There is a thread about the same error message created today (How to solve Preparation failed error during service update) and the problem was in an expired SSL certificate. Maybe your problem is the same; take a look at that.
  • Anthony Blake Profile Picture
    Anthony Blake 943 on at
    Failed deplyment
    So did you just try to apply the same package from LCS as DevOps tried to apply?
     
    I've a growing checklist for preparation failed:
     
    Check admin account is still default in LCS
    Check diskspace
    Check everything closed, e.g. visual studio
    Restart box and retry
    Make sure custom code on the box is in a build state - if not, build models and then restart (no sync needed)
    Rotate secrets (maintain -> Rotate Secrets)
    Finally the sledgehammer approach - provision a replacement
     
     
     
  • CU04051814-0 Profile Picture
    CU04051814-0 170 on at
    Failed deplyment
    Hi Anthony,
     
    Yes, it's a cloud hosted environment, and i tried to restart it but with no luck

    Hi Martin,

    I hope you can answer my previous question, but anyways I clicked apply updates for the latest one through LCS GUI and i got this



    I downloaded the log file:

    in the error pre servicing file, i got this:
    The specified module 'C:\Program Files\Microsoft Security Client\MpProvider' was not loaded because no valid module file was found in any module directory.

    in the log pre servicing file, i got this:
    - Failed to download servicingtools.zip to Server xxx
    ​​​​​​​- Unable to connect to the remote server
    - Generate-Runbook failed...
    StepRetryLimitError:The retry limit for the currently executing step: 3 has been reached
    The value of flag isPreDowntime is: False. Proceeding to stop watchdog service as we're in the downtime.
    The watchdogservice service is not installed. Exiting.
    There are 2 unfinished steps for this pre-servicing run

    Notes:
    my C drive has 40 GB free
    Visual Studio is closed
  • Anthony Blake Profile Picture
    Anthony Blake 943 on at
    Failed deplyment
    Could you share the state of the destination environment in LCS? If its a cloud hosted environment, is it on? Give it a restart,
  • CU04051814-0 Profile Picture
    CU04051814-0 170 on at
    Failed deplyment
    Hi Martin,

    You mean if i go to the VM in LCS and click apply updates?
    but which one i should choose?
    so i've been getting this error for 7 days now, and i ran it each day, where in each day it contained different work items . so if i run the last one, would it take all the work items that failed in different days?

     yesterday, release in devOps failed where there were two work items when i clicked on create release. And today when i clicked release again only 1 new work item appeared, even though yesterday failed -- i was assuming if it failed, then the next time i click release, failed work items in yesterday's release and new items should appear here



    Btw i saw this error in LCS
  • Martin Dráb Profile Picture
    Martin Dráb 224,910 Super User on at
    Failed deplyment
    These warnings (that some commands don't follow the usual naming conventions) aren't important; you can see that the deployment started successfully despite of them. Unfortunately this screenshot doesn't say anything about why it failed.
     
    It seems you're using an Azure DevOps release pipeline. Are you able to deploy the package through LCS GUI?

Helpful resources

Quick Links

Can you answer this forum question?

You could make someone's day!

Community Newsletter - May 2024

Kudos to our community stars!

Community Spotlight of the Month

Kudos to Mohamed Amine Mahmoudi!

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,676 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 224,910 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,146

Featured topics

Product updates

Dynamics 365 release plans