Skip to main content

Notifications

Announcements

No record found.

Microsoft Dynamics AX forum
Answered

Problem with debugger

Posted on by 2,427

Hi All,

Debugger is not showing updated code while debugging.

  • I tried restarting AOS services.
  • Cache cleared
  • Restarting AX client
  • Uncheck Execute Business CIL

Please help me in this case.

Regards,

Raziq.Ali

  • Suggested answer
    Denis Macchinetti Profile Picture
    Denis Macchinetti 16,444 on at
    RE: Problem with debugger

    Hi

    Run AX Client in elevated mode ( Run as administrator )

  • Verified answer
    Dick Wenning Profile Picture
    Dick Wenning 8,705 on at
    RE: Problem with debugger

    Stop the AOS

    go to the server map bin\\XppIL remove all the files, and start the AOS again

  • Suggested answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Problem with debugger

    Did you try to do a complete CIL?

  • sohaibcheema Profile Picture
    sohaibcheema 46,590 User Group Leader on at
    RE: Problem with debugger

    I am not if this can help, but as it did helped me at past, so I would like to add, can you kindly compile your code once again, then do a compile forward. At end Refresh Client configuration. Close AX and reopen.

  • Mohammad Raziq Ali Profile Picture
    Mohammad Raziq Ali 2,427 on at
    RE: Problem with debugger

    Hi,

    Thanks for your reply.

    I have deleted usage data as well.

    Regards,

    Raziq.Ali

  • Iulian Cordobin Profile Picture
    Iulian Cordobin 8,201 on at
    RE: Problem with debugger

    By cache cleared you mean you've deleted the .kti and .auc files or using the Cache menu from within AX client?

    Also, I just realized (reading what object you are trying to debug), can you try to delete the Usage data?

  • Mohammad Raziq Ali Profile Picture
    Mohammad Raziq Ali 2,427 on at
    RE: Problem with debugger

    I am talking about X++ debugger.

    it is CustBalanceList class which I am debugging..

    Thanks,

    Raziq.Ali

  • Martin Dráb Profile Picture
    Martin Dráb 224,741 Super User on at
    RE: Problem with debugger

    Are you talking about X++ or CIL debugger? What type of object are you debugging?

Helpful resources

Quick Links

Can you answer this forum question?

You could make someone's day!

Community Newsletter - May 2024

Kudos to our community stars!

Community Spotlight of the Month

Kudos to Mohamed Amine Mahmoudi!

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,663 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 224,741 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,146

Featured topics

Product updates

Dynamics 365 release plans