Skip to main content

Notifications

Announcements

No record found.

Customer Service forum
Answered

Suddenly missing email ribbon buttons

Posted on by 42

Hello experts,

We have an ongoing issue, which is important buttons of any email entity forms are missing. like convert to case, or refresh or save record in our production environtment.

However on our testing environtment they are available.

There was no import operation, we changed nothing in production, which can cause this.

Here is a picture from sandbox, which shows proper ribbon:

pastedimage1635880091335v1.png

Here is a picture from production, which has limited ribbon functionality as it seems:

pastedimage1635880189475v2.png

Please suggest what can be a root cause for this type of issue.

Categories:
  • C. Jensen Profile Picture
    C. Jensen 384 on at
    RE: Suddenly missing email ribbon buttons

    Hi Thri

    If you haven’t fixed your problem yet, try to publish all customizations.

    I have had the same problem On our solution, and publishing Always fixes the problem.

    It seems to me, that this happens when i make changes to an entity, and only publish that single entity.

  • regex91 Profile Picture
    regex91 42 on at
    RE: Suddenly missing email ribbon buttons

    Hello Thri,

    The exact root cause was not provided to us from Microsoft, I think because we can't solve it within a cloud Dynamics 365 instance, because the backend has defect, which is unreachable to us.

    When Im looked in what can be the cause of this, Leah Ju anwer helped me a lot.

    If you start debugging email form ribbons (add &ribbondebug=true to url https://docs.microsoft.com/en-us/troubleshoot/power-platform/power-apps/ribbon-issues-button-hidden?tabs=delete)

    you can see something like this:
    command_2D00_properties_2D00_new_2D00_hidden.png

    We had an enable rule with always false value, caused by a system owned javascript.

    Further looked this javascript is completely missed in Production environtment, where the buttons dissappeared, but it does existed in sandbox.

    Maybe you have a missing javascript as well, causes a false value, not an error, hence the buttons are not visible.

  • Thri Profile Picture
    Thri 7 on at
    RE: Suddenly missing email ribbon buttons

    Hi, what was the exact fix provided by Microsoft. We are also suddenly facing same issue. Entire ribbon is missing for Email entity in production suddenly. Test env is fine. Ours is On Premise.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Suddenly missing email ribbon buttons

    Hi regex91,

    Thanks for sharing!:)

  • regex91 Profile Picture
    regex91 42 on at
    RE: Suddenly missing email ribbon buttons

    Yes, we confirmed that the problem was not hidecustomactions related.

    We raised a ticket to Microsoft, and the issue solved by them.

    When we asked them, what was the root cause they answered this:

    Issue: Missing buttons on email entity ribbon.

    Resolution: This issue is a known one that resulted from a code defect at the backend, and as such, necessary mitigation was applied to correct the issue at the backend.

    Thank you Leah Ju for your help.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Suddenly missing email ribbon buttons

    Hi regex91,

    Through my test, i found same hidecustomactions flag in folllowing screenshot, but these buttons all show in the bar not missing, so i don't think that's the cause.

    pastedimage1635990247603v1.png

    You'd better to raise a ticket for microsoft for further help.

  • regex91 Profile Picture
    regex91 42 on at
    RE: Suddenly missing email ribbon buttons

    It not worked, however looking at ribbon debug windows this show up:

    pastedimage1635923226044v1.png

    The missing buttons has hidecustomactions flag as I can see!

    How can I undo this?

  • regex91 Profile Picture
    regex91 42 on at
    RE: Suddenly missing email ribbon buttons

    Dear Leah Ju, i already tried in multiple browser and deleted cache as well.

    Currently running ribbon metadata  regeneration, based on your link, if not works we will raise a ticket for microsoft.

    Thank you for your answer.

  • Verified answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Suddenly missing email ribbon buttons

    Hi regex91,

    Have you tried to clear browser cache or change another browser to test?

    It might be JS on button that causes visibility hidden and Check whether is there any display rule on button in Ribbon Workbench

    Or you can refer following link, which helps you resolve issues that affect a ribbon command bar button in a Power Apps model-driven app or a customer engagement app:

    Troubleshooting ribbon issues in Power Apps - Power Apps | Microsoft Docs

    Finally you can log ticket with MS support for assistance:https://admin.powerplatform.microsoft.com/support

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,459 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,783 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans