I know Integration Manager is near and dear to our hearts, but we have to admit it is becoming more and more 'outdated' for our fast lifestyles we all like to live in.  Many times in support we are asked how can you make Integration Manager run faster or I'm running this large integration and it continually stops at about 300 checks and errors with RPC Server is unavailable.  How can we troubleshoot this error message with Integration Manager?

1. The first item we would like you to try with this error message is can you import a bit smaller set of data and see if it will then go through.  If it does, we know your integration is working well this error is related to the size of our import.

2. There are a few things that I have seen cause a performance hit, when using Integration Manager. The main one being the Connect gadget on the homepage. You can try disabling Connect on the machine that is running IM from the homepage:

A. In Dynamics GP, login to your company.
B. On the homepage, in the upper right hand corner, click Customize this page…
C. Uncheck the box next to Connect and click OK

3. Another item to check is log into Dynamics GP as the user who is logged in when the integration is run, go to Microsoft Dynamics GP > User Preferences and change Window Command Display from "Action Pane" to "Menu Bar". Then close and launch Microsoft GP again, logging in as the same user and running the integration in question. We have seen some performance gains when using this version of the menu system.

If the user prefers the Action Pane for their everyday work you could create a separate integration user for them that uses the Menu Bar so they log in as that user when running IM.

4. Close all running instances of Microsoft Dynamics GP and open Windows Task Manager. Under the Processes tab, verify that there is not more than one instance of the Dynamics.exe process running.  I would recommend that you launch GP by right-clicking on its icon and selecting Run as Administrator. Then launch IM in the same manner. This typically gives better results due to the elevated permissions. If it seems to work for your situation you can go to the properties for these two shortcuts and mark the option to always launch them as Admin.

5. We could try to run this directly at the server, just to rule out connection issues see if it makes a difference.

Using the standard adapter will simply run a large macro that will run through GP to integrate the transactions. When you are doing integrations that large, it will take some time.

You could look at using the eConnect adapters if there is one available for whatever type of integration you are doing.
Or using eConnect itself over Integration Manager. This should perform better, as it is not actually running through the GP client front end and using a macro to do the work

Thanks, 

Terry Heley

Microsoft