Sales Transactions Smartlist - error searching for Master Number

Question Status

Verified
SMike Giuffre asked a question on 21 Apr 2017 9:09 AM

I'm curious if this is unique to our environment or if anyone else receiving this error.  Adding the Master Number column to the Sales Transactions Smartlist in GP 2015R2, then attempting to search on the Master Number yields me "Unhandled script exception: Bad power value EXCEPTION_CLASS_SCRIPT_OUT_OF_RANGE SCRIPT_CMD_POWER".  When I click OK the search bails and I don't get expected results.

I've found a citation to this same error that suggests changing the data type resolves it.  I do have a custom Smartlist that I added Master Number to and received the same error.  I had the luxury of changing the data type of the Master Number to string, as the found citation indicated, and this resolved the error in my custom Smartlist.  I am not aware of how to change the data type on a column in a stock GP Smartlist like Sales Transactions.

Any information to share about resolving this would be appreciated.

Reply
Suggested Answer
Tim Wappat responded on 21 Apr 2017 4:50 PM

14.00.0952(GP2015R2)

Added Master Number to Sales Transaction Smartlist.

Then used the Master Number Field to search and it worked fine when I tried it.

Then tried each of the conditions (begins with, contains, etc), they too worked normally.

I then did some thinking and research and changed the master number display option to show comma as a separator. On attempting the search again I now got the same exception as you.

i wrote it up in a blog post:

www.timwappat.info/.../Bad-Power-Value-from-searching-on-master-number-in-sales-transaction-smartlist-Dynamics-GP

Essentially remove any field formatting from the master number field and it should work again. 

Tim

Reply
Verified Answer
SMike Giuffre responded on 26 Apr 2017 9:32 AM

The standard Sales Transaction Smartlist I have in GP has no formatting for the Master Number field.  What's odd is in checking that I clicked to "Modify" the Smartlist, then removed the modified Smartlist.  That seemed to solve my problem as it works now.  I think there's issues with modifying existing Smartlists as we had another problem with 1/1/1900 dates when someone else modified another existing Smartlist.

Reply
Verified Answer
SMike Giuffre responded on 26 Apr 2017 9:32 AM

The standard Sales Transaction Smartlist I have in GP has no formatting for the Master Number field.  What's odd is in checking that I clicked to "Modify" the Smartlist, then removed the modified Smartlist.  That seemed to solve my problem as it works now.  I think there's issues with modifying existing Smartlists as we had another problem with 1/1/1900 dates when someone else modified another existing Smartlist.

Reply
Suggested Answer
Tim Wappat responded on 21 Apr 2017 4:50 PM

14.00.0952(GP2015R2)

Added Master Number to Sales Transaction Smartlist.

Then used the Master Number Field to search and it worked fine when I tried it.

Then tried each of the conditions (begins with, contains, etc), they too worked normally.

I then did some thinking and research and changed the master number display option to show comma as a separator. On attempting the search again I now got the same exception as you.

i wrote it up in a blog post:

www.timwappat.info/.../Bad-Power-Value-from-searching-on-master-number-in-sales-transaction-smartlist-Dynamics-GP

Essentially remove any field formatting from the master number field and it should work again. 

Tim

Reply