I have done some changes in one class. That class is running on the server side. It is related to the service operations. The attribute SysEntryPointAttribute is used in that class method for decorate. This class is used for batch job process. The problem is that my changes are not reflecting.

The solution for this issue is that we need to do the incremental CIL. So, I tried the incremental CIL. But, I got one error message “Cannot create a record in SysXppAssembly (SysXppAssembly). The record already exists.”

I thought AOS restart will solve this issue, but not worked.

So, I did the following steps. It worked.

  1. Stop the AOS
  2. Navigate to the XppIL folder in your AOS server “C:\Program Files\Microsoft Dynamics AX\60\Server\YourAXInstanceName\bin\XppIL”
  3. Backup the files from the XppIL folder.
  4. Delete the files from the XppIL folder. Note: files only not sub folders.
  5. Restart the AOS
  6. The XppIL folder files will be created after the AOS restart

I tried the incremental CIL, Incremental CIL is completed successfully.