SBX - Search With Button

SBX - Forum Post Title

Flashing Cursor in Outlook 2013 with CRM 2015 for Outlook installed

Microsoft Dynamics CRM Forum

Merlin asked a question on 20 Jul 2015 7:37 PM
My Badges

Question Status

Verified

Have HP Envy 17T with Windows 8.1 and Office 365 PowerPro 64 bit installed.  Outlook worked fine until I installed CRM 2015 for Outlook.  Now when CRM is loading in Outlook the cursor starts flashing from Normal to Busy rapidly and will not stop.  Can't type (unless I catch a second between busy and normal).  I uninstalled CRM 2015 for Outlook and it is working fine.  However, I really need CRM for Outlook working.

I can start Outlook as Administrator and it doesn't create the flickering cursor.

Hope someone can help.

Thanks,

Merlin Siefken

Reply
Piyush Jain responded on 23 Jul 2015 6:15 PM
My Badges

Hi ,

What is the CRM Client for outlook version on  ?

What is the CRM Server Version ?

Try to disable all other addin from outlook and  try.

Reply
Merlin responded on 23 Jul 2015 8:41 PM
My Badges
Suggested Answer

I reported the problem via our Office 365 administration web and received a call the next day from Gaurav Tempe who was very helpful.  We identified that the root cause of the issue was the missing config file.  There was no webformhost.exe process in Task Manager.  We created an empty config file on the desktop and named it as "Microsoft.CRM.Application.Outlook.WebFormsHost.exe.config" and imported this file in the folder: Program Files>>>res>>>web>>bin

Problem is resolved.

Reply
Sean Maisonneuve responded on 25 Jul 2015 12:51 PM

Hi Merlin,

Some of our users had the same problem and your fix did work.  The only confusing part was the file path you indicated.  Instead of:

Program Files>>>res>>>web>>bin

It should be:

C:\Program Files\Microsoft Dynamics CRM\Client\res\web\bin

Thanks for the fix!

Sean

Reply
Yaroslav Archakov responded on 28 Jul 2015 12:11 AM
My Badges
Verified Answer

It worked! Thanks!

Reply
Buzzlit responded on 27 Jan 2016 3:36 PM

This also fixed my issue.  Outlook 2010, CRM 2015, constant flashing.  However I noticed when I double click on records in Outlook CRM 2015 that it doesn't pop up in an IE window.  IE is set to my default browser.  Am I missing something simple or does the newly created config file need to be populated with something?

Reply
Chen Chiu responded on 14 Jul 2016 1:35 PM

Same here.  With the empty config file, the flashing stopped.  BUT I can no longer open up any CRM records from my Outlook CRM plugin.

We've had this problem for a long time already.  We had received word from Microsoft that once CRM was upgraded to 2015 the problem would go away.  No!  Flashing without the config file, and inability to open CRM records with the empty config file.  I have no choice but to go without the config file and close my Microsoft Dynamics GP 2015 whenever flashing starts.  I cannot understand why Microsoft CRM 2015 would not be compatible with Microsoft Great Plains 2015 ?!

Please, can someone help.

Reply
Peter Coppens responded on 11 Oct 2016 4:32 AM
My Badges
Suggested Answer

We were having similar issues with Outlook 2013 and the CRM 2013 client installed on Windows 8.1.  Even installing the "Update Rollup 4 for Microsoft Dynamics CRM 2013 Service Pack 1" did not fix the issue.

As a workaround we've granted "requireAdministrator" security level to the Outlook executable using the OUTLOOK.EXE.MANIFEST file.  Note that our CRM users have administrator privileges on their local computer.

C:\Program Files (x86)\Microsoft Office\Office15\OUTLOOK.EXE.MANIFEST

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
	<noInherit></noInherit>
	<assemblyIdentity processorArchitecture="*" type="win32" name="outlook" version="1.0.0.0"></assemblyIdentity>
	<description>Microsoft Office Outlook</description>
	<trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
		<security>
			<requestedPrivileges>
				<!-- <requestedExecutionLevel level="asInvoker" uiAccess="false"></requestedExecutionLevel> -->
				<requestedExecutionLevel level="requireAdministrator" uiAccess="false"></requestedExecutionLevel>
			</requestedPrivileges>
		</security>
	</trustInfo>
	<compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1"> 
		<application>
			<!--The ID below indicates application support for Windows 7 -->
			<supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"></supportedOS>
			<!--This Id value indicates the application supports Windows 8 functionality-->
			<supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}"></supportedOS>
			<!-- This Id value indicates the application supports Windows 8.1 functionality-->
			<supportedOS Id="{1f676c76-80e1-4239-95bb-83d0f6d0da78}"></supportedOS>
			<!-- This Id value indicates the application supports Windows 10 functionality-->
			<supportedOS Id="{8e0f7a12-bfb3-4fe8-b9a5-48fd50a15a9a}"></supportedOS>
		</application> 
	</compatibility>
	<asmv3:application xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
		<asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
			<dpiAware>true</dpiAware>
		</asmv3:windowsSettings>
	</asmv3:application>
	<dependency optional="yes">
		<dependentAssembly>
			<assemblyIdentity type="win32" name="Microsoft.Windows.Common-Controls" version="6.0.1.0" publicKeyToken="6595b64144ccf1df" language="*" processorArchitecture="*"></assemblyIdentity>
		</dependentAssembly>
	</dependency>
</assembly>


 Also our "Microsoft.CRM.Application.Outlook.WebFormsHost.exe.config" file is not empty, but instead contains the following:

<configuration>
	<system.net>
		<defaultProxy enabled="false" useDefaultCredentials="true" >
			<proxy autoDetect="false" />
		</defaultProxy>
	</system.net>
</configuration>


You may want to adapt this to correspond with the proxy settings applicable for your network.

Reply
Yaroslav Archakov responded on 28 Jul 2015 12:11 AM
My Badges
Verified Answer

It worked! Thanks!

Reply
Merlin responded on 23 Jul 2015 8:41 PM
My Badges
Suggested Answer

I reported the problem via our Office 365 administration web and received a call the next day from Gaurav Tempe who was very helpful.  We identified that the root cause of the issue was the missing config file.  There was no webformhost.exe process in Task Manager.  We created an empty config file on the desktop and named it as "Microsoft.CRM.Application.Outlook.WebFormsHost.exe.config" and imported this file in the folder: Program Files>>>res>>>web>>bin

Problem is resolved.

Reply
Peter Coppens responded on 11 Oct 2016 4:32 AM
My Badges
Suggested Answer

We were having similar issues with Outlook 2013 and the CRM 2013 client installed on Windows 8.1.  Even installing the "Update Rollup 4 for Microsoft Dynamics CRM 2013 Service Pack 1" did not fix the issue.

As a workaround we've granted "requireAdministrator" security level to the Outlook executable using the OUTLOOK.EXE.MANIFEST file.  Note that our CRM users have administrator privileges on their local computer.

C:\Program Files (x86)\Microsoft Office\Office15\OUTLOOK.EXE.MANIFEST

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
	<noInherit></noInherit>
	<assemblyIdentity processorArchitecture="*" type="win32" name="outlook" version="1.0.0.0"></assemblyIdentity>
	<description>Microsoft Office Outlook</description>
	<trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
		<security>
			<requestedPrivileges>
				<!-- <requestedExecutionLevel level="asInvoker" uiAccess="false"></requestedExecutionLevel> -->
				<requestedExecutionLevel level="requireAdministrator" uiAccess="false"></requestedExecutionLevel>
			</requestedPrivileges>
		</security>
	</trustInfo>
	<compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1"> 
		<application>
			<!--The ID below indicates application support for Windows 7 -->
			<supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"></supportedOS>
			<!--This Id value indicates the application supports Windows 8 functionality-->
			<supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}"></supportedOS>
			<!-- This Id value indicates the application supports Windows 8.1 functionality-->
			<supportedOS Id="{1f676c76-80e1-4239-95bb-83d0f6d0da78}"></supportedOS>
			<!-- This Id value indicates the application supports Windows 10 functionality-->
			<supportedOS Id="{8e0f7a12-bfb3-4fe8-b9a5-48fd50a15a9a}"></supportedOS>
		</application> 
	</compatibility>
	<asmv3:application xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
		<asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
			<dpiAware>true</dpiAware>
		</asmv3:windowsSettings>
	</asmv3:application>
	<dependency optional="yes">
		<dependentAssembly>
			<assemblyIdentity type="win32" name="Microsoft.Windows.Common-Controls" version="6.0.1.0" publicKeyToken="6595b64144ccf1df" language="*" processorArchitecture="*"></assemblyIdentity>
		</dependentAssembly>
	</dependency>
</assembly>


 Also our "Microsoft.CRM.Application.Outlook.WebFormsHost.exe.config" file is not empty, but instead contains the following:

<configuration>
	<system.net>
		<defaultProxy enabled="false" useDefaultCredentials="true" >
			<proxy autoDetect="false" />
		</defaultProxy>
	</system.net>
</configuration>


You may want to adapt this to correspond with the proxy settings applicable for your network.

Reply

SBX - Two Col Forum

SBX - Migrated JS