I am told we have CRM on one server, and had two Sandbox's setup on two other servers, for our in-house install of CRM 2015 - and that one Sandbox server has been removed. 

We are also getting random exceptions, with

System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=7.0.0.0, Culture=neutral, PublicKeyToken= ... ]]: The plug-in execution failed because no Sandbox Hosts are currently available. Please check that you have a Sandbox server configured and that it is running.
System.ServiceModel.EndpointNotFoundException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #E1D2A870Detail: 
<OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
  <ErrorCode>-2147220891</ErrorCode>
  <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic">
    <KeyValuePairOfstringanyType>
      <d2p1:key>OperationStatus</d2p1:key>
      <d2p1:value xmlns:d4p1="http://www.w3.org/2001/XMLSchema" i:type="d4p1:string">0</d2p1:value>
    </KeyValuePairOfstringanyType>
    <KeyValuePairOfstringanyType>
      <d2p1:key>SubErrorCode</d2p1:key>
      <d2p1:value xmlns:d4p1="http://www.w3.org/2001/XMLSchema" i:type="d4p1:string">-2146233088</d2p1:value>
    </KeyValuePairOfstringanyType>
  </ErrorDetails>
  <Message>The plug-in execution failed because no Sandbox Hosts are currently available. Please check that you have a Sandbox server configured and that it is running.
System.ServiceModel.EndpointNotFoundException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #E1D2A870</Message>
  <Timestamp>2019-09-10T15:24:05.6821097Z</Timestamp>
  <InnerFault i:nil="true" />
  <TraceText>

I spent a day, found many entries for this error, but seems most represent a second full CRM Sandbox instance - none referencing a Sandbox instance for the plug-ins or how to handle change in configuration.

Another person here thinks that the plug-in may somehow be referencing the removed server and that is why it is failing? But he doesn't know how to find the solution either and tasked me to.

Is there a way within CRM or anywhere to see the servers assigned to CRM to be used as the plug-in Sandbox server?  If the plug-ins use a full Sandbox - same question - how to find and verify the second sandbox configuration information is still present?

Thank you,

Todd