SBX - Search With Button

SBX - Forum Post Title

Dynamics CRM Stuck at Loading Business Logic in Chrome

Dynamics 365 for Customer Service Forum

Sreelatha asked a question on 26 Mar 2019 11:16 PM

Question Status

Suggested Answer

With Chrome upgrade to Version 73.0.3683.86, Dynamics CRM both Online and On-premise are having an issue with loading form and stuck at Loading Business Logic.

This happens only when a record is opened from related entity associated view or from sub-grid.  No issues when navigated directly to open form from navigation menu or advance find.

Please note that this issue is only with Chrome and not with IE and also converting to TurboForm is not an option for us.

When I looked at the console, there were some javascript errors related to Mscrm.TurboForm.Control.CustomScriptsManager.frameElement.contentWindow.... is not a function

Reply
LeoAlt responded on 27 Mar 2019 1:47 AM
My Badges

Hi partner,

My chrome is also Version 73.0.3683.86 and I opened a record from sub-grid and I have not found this issue.

My Dynamics 365 instance is  Version 1710 (9.1.0.3056) online.

But I've also met this issue in the community, So I suggest that you could use earlier version Chrome first and raise a ticket to Microsoft Team for more support.

Hope it helps.

Best Regards,

Leo

Reply
Huber responded on 27 Mar 2019 4:05 AM

Hey

We have found exactly the same problem today. With refresh the record can be loaded.
Any workarounds?
Reply
Jeison Souza responded on 27 Mar 2019 9:47 AM

Same thing here.

Tested also with the Chrome Beta Version 74.0.3729.28 (Build officiel) beta (64 bits) and it has this same BUG.

CRM On-Premise Version 1612 (9.0.2.3034)

I suspect this error occours only on custom entities, navigating between system user and other sub-grids as example doesn't seems to trigger this bug.

Reply
Greg_ responded on 27 Mar 2019 12:19 PM
My Badges

Also having the same issue, 365 online, Chrome 73.0.3683.86

Reply
Nazer Masih responded on 27 Mar 2019 3:59 PM
My Badges
Suggested Answer

This is a Known issue and Microsoft is aware of this . For now the workaround is to use Internet Explorer.

This issue is only with users who upgraded Chrome to Version 73.0.3683.86

Reply
Dominic Liu responded on 27 Mar 2019 9:05 PM

Same issue here, hope Microsoft can quickly fix this.

Reply
Dominic Liu responded on 27 Mar 2019 9:25 PM

Also we can downgrade the chrome version, the problem will be fixed.

Reply
Hugo Morillo responded on 28 Mar 2019 12:25 AM

I found the same issue

Google Chrome version: 73.0.3683.86

CRM Version: Dynamics 365 8.2.4.6 OnPremise

community.dynamics.com/.../314939

Reply
Jeison Souza responded on 29 Mar 2019 9:18 AM
Suggested Answer

MS gave us two workarounds:

The first one is to add an empty onload handler (javascript function) to the entity form and it allows the form to load in Chrome.

The second one is to activate the « Use legacy form rendering »

We tested both methods in Chrome, and it works.


MS, told us that they are working for a solution On Line, but it can take a while to be released On Premise.

Reply
Nazer Masih responded on 30 Mar 2019 8:47 PM
My Badges
Suggested Answer

For online customers the fix is expected to be deployed this weekend..

Reply
GGarcia responded on 2 Apr 2019 2:58 PM

We are seeing this as well with this version of Chrome and with on premises version 1612 (8.2.3.8) (DB 8.2.3.8).  

Reply
Yvan Leclerc responded on 9 Apr 2019 8:26 AM
My Badges

Same here... Chrome version 73 + CRM 8.2 on-premise

Reply
Yvan Leclerc responded on 9 Apr 2019 8:34 AM
My Badges

Jeison - So you just add an onload event on affected forms?

Something like this?

function FixChromeBug() {  

//do nothing

}

Reply
Jeison Souza responded on 9 Apr 2019 8:50 AM

Yeap, but MS already released an update that fixes it, so life is back to normal.

V9 0.3

support.microsoft.com/.../microsoft-dynamics-365-onpremise-cumulative-updates

Reply
Fedor Patutinskiy responded on 30 Apr 2019 1:21 AM

Hello!

I am exposing the same issue for Dynamics CRM 2016 version. Could you please advice if there will be any rollup for this version?

Reply
Nazer Masih responded on 27 Mar 2019 3:59 PM
My Badges
Suggested Answer

This is a Known issue and Microsoft is aware of this . For now the workaround is to use Internet Explorer.

This issue is only with users who upgraded Chrome to Version 73.0.3683.86

Reply
Jeison Souza responded on 29 Mar 2019 9:18 AM
Suggested Answer

MS gave us two workarounds:

The first one is to add an empty onload handler (javascript function) to the entity form and it allows the form to load in Chrome.

The second one is to activate the « Use legacy form rendering »

We tested both methods in Chrome, and it works.


MS, told us that they are working for a solution On Line, but it can take a while to be released On Premise.

Reply
Nazer Masih responded on 30 Mar 2019 8:47 PM
My Badges
Suggested Answer

For online customers the fix is expected to be deployed this weekend..

Reply

SBX - Two Col Forum

SBX - Migrated JS