Use Impersonation is not shown

Question Status

Verified
Donny Riyadi Santoso asked a question on 7 Sep 2015 9:45 AM

Hi,

I have an installation where I dont see the field Use Impersonation on Email Server Profile if I set the field Authenticate Using = Credentials Specified in Email Server Profile.

What is the problem ?
Thanks a lot.

Reply
Suggested Answer
Manoj Batchu responded on 7 Sep 2015 3:59 PM

Hi,

You will have option to Use Impersonation on both the options either you select 'Credentials Specified by a User or Queue' or 'Credentials Specified in Email Server Profile'.

Reply
Donny Riyadi Santoso responded on 8 Sep 2015 2:56 AM

Thats exactly my problem. I have set it to Credentials Specified in Email Server Profile but still this field is not shown.

Reply
Verified Answer
novumni responded on 15 Sep 2015 3:59 AM

This is a bug in MSCRM. Only way is to open Developer Toolbar, find the hidden "Use Impersonation" field, make it visible, then enable it and save.

Hopefully MS will fix this soon. Seems that sometimes it works, but in most cases this field keeps hidden.

Reply
BillH12 responded on 19 Nov 2015 12:04 PM

Did you find a way to have it shown?  I have the same problem as you after updating CRM to Update 0.1

My test CRM server (not update) shows it.

Reply
Adam Gray responded on 26 Nov 2015 2:43 PM

I'm seeing this issue on Update 0.1 and 0.2. I can find the field and make it visible, and set a new value, but the updated value does not save. I must be missing something, can you give a bit more detail on how you've resolved this? Thanks.

Reply
Verified Answer
novumni responded on 27 Nov 2015 10:02 AM

Its not clear why sometimes the field is not visible. But it is there, its just hidden.

In order to set it, open the developer toolbar (available on most browsers) and simply enable the inspect function, then click the area where you would expect this radio button to appear. Now look up the HTML code, you can see the element which is set invisible. Remove this style and it wil show up. Now you can set it and save.

Reply
Donny Riyadi Santoso responded on 28 Nov 2015 9:53 AM

Yes that was also my solution.

Reply
BillH12 responded on 30 Nov 2015 1:19 PM

Can you give me a bit more detail steps to see this?  I am not a developer, but a network guy.  I handle the setup and administration of the server.  I am using IE 11 to access the site.  I press F12 to turn on the Developer Tool, but I'm not sure where to go from there.

Reply
novumni responded on 1 Dec 2015 6:52 AM

Once the toolbar is open on the very left side there is a button. Something with a pointer. This allows you to click any element on the site to show it up on the developer toolbar. Click somewhere nearby where normally expect the missing element. Now on the toolbar you see the html part of that clicked element. Look closer you should see the html node with an id attribute named like "...impersonation...". Once you found you will see it has an attribute for visibility. Remove it so it will show up. It might take some time to find that element but it's definitely there. Now you can edit it and save as usual.

Reply
CharlesScheuber responded on 2 Dec 2015 4:43 PM

Hi Guys,

Thanks for these tips. I found that i could enable outbound impersonation just by changing outbound to use its own settings.


For inbound, the above steps are requried, and necessary for the Appointments/Tasks/Contacts to Sync. 


When i follow your steps however, i am able to get the fields visible on the form, however they are read-only, i cannot swap to yes. Did you guys have a workaround for that?

Thanks, Charles

Reply
CharlesScheuber responded on 2 Dec 2015 4:55 PM

Hello Again Already,

For those that have the same issue where the field remains read-only:

>Head into Customization for your solution

>Email Server Profile

>Fields

>Find "incomingimpersonateuser"

>set its default value to Yes

Recreate your exchange profile.

All that said, i can imagine the fact this field is invisible can only be of two reasons:

1. A mistake

2. MS have current concerns over reliability

Will keep a close eye on our SSS for some time!

Thanks for the tips.

Reply
novumni responded on 3 Dec 2015 3:52 AM

Hi,

of course you have to enable the radio button as well. Once you found it, look for the disabled attribute and remove it. You really need to "hack" it and make it visible and clickable. Once clickable, just set it to Yes and you can save it.

Reply
BillH12 responded on 3 Dec 2015 4:28 PM

Thank you for the tips.  Will give this a try when I get back into the office.

Reply
Verified Answer
novumni responded on 15 Sep 2015 3:59 AM

This is a bug in MSCRM. Only way is to open Developer Toolbar, find the hidden "Use Impersonation" field, make it visible, then enable it and save.

Hopefully MS will fix this soon. Seems that sometimes it works, but in most cases this field keeps hidden.

Reply
Verified Answer
novumni responded on 27 Nov 2015 10:02 AM

Its not clear why sometimes the field is not visible. But it is there, its just hidden.

In order to set it, open the developer toolbar (available on most browsers) and simply enable the inspect function, then click the area where you would expect this radio button to appear. Now look up the HTML code, you can see the element which is set invisible. Remove this style and it wil show up. Now you can set it and save.

Reply
Suggested Answer
Manoj Batchu responded on 7 Sep 2015 3:59 PM

Hi,

You will have option to Use Impersonation on both the options either you select 'Credentials Specified by a User or Queue' or 'Credentials Specified in Email Server Profile'.

Reply