Import wizard - date field being converted to wrong format using Excel file

Question Status

Suggested Answer
Peter Clements asked a question on 6 Sep 2017 11:27 AM

Hi,

So, we've hit some problems importing to a custom entity in Dynamics 365 Sales (online). The custom entity has a date field set to date / time with date only showing. The source data in Excel is in date only format set to UK (dd/mm/yy). The system is set to UK format and the logged in user is set to UK format.

When the data is imported the entries in the date field are being converted into US format (mm/dd/yy) - some get imported (incorrectly) and some don't as they don't match the format.

I've seen lots of blogs about this but most seem to point to the user / system settings which I am confident are set correctly.

Oh - if we do it via CSV using the same data - it works fine.

Does anyone know what's going on here?

Peter.

Reply
Suggested Answer
Wayne Walton responded on 6 Sep 2017 11:30 AM

Try setting Excel to ISO standard  YYYY/MM/DD. That generally eliminates ambiguity, and then your CRM will still render UK standard dates since the CRM database is storing it all as ISO anyway.

Reply
Peter Clements responded on 6 Sep 2017 2:15 PM

Hi Wayne,,

Thanks for replying. I find it hard to believe that is the answer. Does this not suggest a problem with the import process from XL?

Reply
Wayne Walton responded on 6 Sep 2017 2:19 PM

Excel and CRM's data types aren't 1:1.  There's also limitations like Excel freaking out if you have two display names on attributes that are the same.  It could be a bug, or it could be a design limitation.  Either way, changing the date standard in Excel should be a valid workaround.  But yes, you might also want to submit that as a bug, so MS can see it.

Reply
Suggested Answer
Wayne Walton responded on 6 Sep 2017 11:30 AM

Try setting Excel to ISO standard  YYYY/MM/DD. That generally eliminates ambiguity, and then your CRM will still render UK standard dates since the CRM database is storing it all as ISO anyway.

Reply