Hi

We configured our CRM router to set out mails using O365 mail service, we have custom workflows that generate mails. recently we figured the mail sending delay where all mails include entity email (Eg : Contact) in CC or To. 

But when i put test mail form activities option to CRM user is sending mail in regular way where no delay

in event viewer i found following two errors repeated way 

Error 1

#26234 - The E-mail Router service could not process a provider work item using assembly: Microsoft.Crm.Tools.EmailProviders.dll and class: Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider. System.NullReferenceException: Object reference not set to an instance of an object.
at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.HandleProcessMessageError(Exception exception, Entity emailMessage)
at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()
at Microsoft.Crm.Tools.Email.Agent.ServiceCore.ExecuteProviderWork(Object providerQueueRequestObject)

Error 2

#61042 - An error occurred while processing the outgoing e-mail message with subject "Passport Expiry Reminder" for ExchangeOnline: http://ABC/TC for delivery through outlook.office365.com/.../Exchange.asmx. Microsoft.Crm.Tools.Email.Providers.EmailException: Error: At least one recipient isn't valid., Recipient "THEBUWANAGE T G FERNANDO YASEEN" isn't resolved. All recipients must be resolved before a message can be submitted.
at Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider.LogEwsResponseErrorWarning(String message, ResponseClassType responseClassType)
at Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider.ProcessMessageInternal(Entity emailMessage)
at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()

Please any one have same problem solve or any solution highly appreciate

Kind Regards

Radika