Missing Journal Entries Detail

Question Status

Unanswered
Johansen P. asked a question on 13 Feb 2014 5:56 AM

In our system, journal entries are disappearing(being deleted) from  work table GL10001, only header information (GL10000) remains.

This does not happens all the time and we haven't been able to replicate the problem.

We set a trace to determine commands and user who causes the problem. To the moment it seems to occur when the General Transaction windows opens, by any user with access and the commands recorded go from DELETE FROM GL10001 to executing the procedure normally used by the window when the user presses Delete Button.

Since the user password is encrypted, there is no way they are accessing the database directly to run command like DELETE FROM, it seems to be executed by Dynamics itself.

This also happened in the previous installation on GP 2010.

Our partner has implemented some customization via VBA, but nothing on that particular window.

What could be triggering these massive deletion.

Regards,

Reply
Ian Stewart responded on 14 Feb 2014 2:56 PM

Very strange behaviour. Not a known issue. Have a look at the triggers on that table in SSMS. compare them to a fresh install of GP.

Ian.

Reply
Leslie Vail responded on 15 Feb 2014 12:23 AM

Hi,

As you already know, the GL10001 table holds the GL distributions.  You can delete records from that table simply be deleting a row in the transaction entry window. Go to Edit - Delete Row. You don't need to access it outside of the user interface, nor do you need to hit the 'Delete' button.  In your trace, did it delete the detail as the window opened, or was the window just open when the delete occurred?

As Ian advised, this is strange behavior.

Kind regards,

Leslie

Reply
Somakarpagamoorthy Kanagasabapathy responded on 17 Feb 2014 3:10 AM

Restore the company DB to test company and disable all the 3rd party customization in customization status window (Tools-->Customize-->Customization Status)  then create a JE and delete. Now check whether the JE properly deleted or not.

Your reply is much appreciated.

Reply
Johansen P. responded on 17 Feb 2014 5:26 AM

Thanks for the answer, indeed this is an strange behavior, the event is not happening by the user pressing the Delete button because all the entry details are being erased at once and we are talking about hundreds of Journal Entries, it is not possible that the user enters each JE to delete the details.

We have set up activity tracking and right before the deletes are recorded by an trigger we created for that matter, the Transaction entry window is opened, is it like when that window opens if there is a lock, I may guess, it starts deleting the detail records.

Reply
Johansen P. responded on 17 Feb 2014 5:31 AM

I'll try that, but this doesn't happens all the time, it mostly occurs near the month closing process, where there are lots of JE pending to be post, in everyday use it works as a charm.

We have tested creating and deleting JEs with no errors, haven't tried disabling first customization, so I'll do that too.

Reply
Somakarpagamoorthy Kanagasabapathy responded on 17 Feb 2014 6:31 AM

If any 3rd party customization has written wit delete DB in dexterity code, may this is cause of the issue. So, better try disabling all the customization and test this scenario in test environment.

Reply
jmotto responded on 17 Feb 2017 8:21 AM

Did anyone ever find the issue?  We had this happen this month and have not been able to figure out what happend.

Reply